<!DOCTYPE html>
<html dir="ltr" lang="en-gb">
<head>
      <base href="http://phinfever.com/index.php/9-blog/355-56-miami-dolphin-mocks-with-comments" />
  <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="keywords" content="Phinfever, Phinfever.com, Miami Dolphins, Fan Site, Miami Dolphins iPhone wallpapers, Miami Dolphins iPad wallpapers, Miami Dolphins fight song, ring tones, animated gifs, Dan Marino, Ryan Tannehill, Brent Grimes." />
  <meta name="author" content="David Blake" />
  <meta name="description" content="Phinfever - A Miami Dolphins daily fan site. Catch the Madness!" />
  <meta name="generator" content="Joomla! - Open Source Content Management" />
  <title>56 Miami Dolphin Mocks with Comments</title>
  <link href="http://phinfever.com/index.php/9-blog/355-56-miami-dolphin-mocks-with-comments" rel="canonical" />
  <link href="/templates/dd_goldenline_32/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
  <link rel="stylesheet" href="/media/system/css/modal.css" type="text/css" />
  <link rel="stylesheet" href="/components/com_imageshow/assets/css/style.css" type="text/css" />
  <link rel="stylesheet" href="/plugins/jsnimageshow/themeslider/assets/css/style.css" type="text/css" />
  <link rel="stylesheet" href="/plugins/jsnimageshow/themeslider/assets/css/skitter/skitter.styles.css" type="text/css" />
  <style type="text/css">
.jsn-themeslider-skitter-knUzJ .label_skitter {filter:alpha(opacity=75);opacity: 0.75;}.jsn-themeslider-skitter-knUzJ .label_skitter p.jsn-themeslider-caption-title {font-family: Verdana;
font-size: 12px;
font-weight: bold;
text-align: left;
color: #E9E9E9;}.jsn-themeslider-skitter-knUzJ .label_skitter p.jsn-themeslider-caption-description {font-family: Arial;
font-size: 11px;
font-weight: normal;
text-align: left;
color: #AFAFAF;}.jsn-themeslider-skitter-knUzJ .label_skitter a.jsn-themeslider-caption-link {font-family: Verdana;
font-size: 11px;
font-weight: bold;
text-align: right;
color: #E06614;}.jsn-themeslider-skitter-knUzJ .info_slide {top: 15px;}.jsn-themeslider-skitter-knUzJ .info_slide_dots {top: 15px;}
  </style>
  <script src="/media/jui/js/jquery.min.js" type="text/javascript"></script>
  <script src="/media/jui/js/jquery-noconflict.js" type="text/javascript"></script>
  <script src="/media/jui/js/jquery-migrate.min.js" type="text/javascript"></script>
  <script src="/media/system/js/tabs-state.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-core.js" type="text/javascript"></script>
  <script src="/media/system/js/core.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-more.js" type="text/javascript"></script>
  <script src="/media/system/js/modal.js" type="text/javascript"></script>
  <script src="/media/system/js/caption.js" type="text/javascript"></script>
  <script src="/components/com_imageshow/assets/js/jquery.min.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/jsn_is_conflict.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.easing.1.3.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.animate-colors-min.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.skitter.js" type="text/javascript"></script>
  <script type="text/javascript">

		window.addEvent('domready', function() {

			SqueezeBox.initialize({});
			SqueezeBox.assign($$('a.modal'), {
				parse: 'rel'
			});
		});window.addEvent('domready', function() {
			$$('.hasTip').each(function(el) {
				var title = el.get('title');
				if (title) {
					var parts = title.split('::', 2);
					el.store('tip:title', parts[0]);
					el.store('tip:text', parts[1]);
				}
			});
			var JTooltips = new Tips($$('.hasTip'), {"maxTitleChars": 50,"fixed": false});
		});jQuery(window).on('load',  function() {
				new JCaption('img.caption');
			});function  spsyt(a, b, c){
			var id = document.id(a);
			var w = id.getParent().getWidth();
			var h = (c*w)/b;
			id.setStyles({
				'width': w,
				'height': h
			});
		}
  </script>
  <!-- start - swMenuFree 8.3_J2.5-J3.0 javascript and CSS links -->
  <script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/jquery-1.6.min.js"></script>
  <style type='text/css'>
<!--
#sfmenu {
 border-width: 3px ;
 border-color: #17050E ;
 padding-top: 16px ;
 padding-right: 10px ;
 padding-bottom: 14px ;
 padding-left: 10px ;
background-image:none ;
}
.sw-sf, .sw-sf * {
margin: 0  ; 
padding: 0  ; 
list-style: none  ; 
}
.sw-sf {
line-height: 1.0  ; 
}
.sw-sf hr {display: block; clear: left; margin: -0.66em 0; visibility: hidden;}
.sw-sf ul{
position: absolute; 
top: -999em; 
width: 10em; 
display: block; 
}
.sw-sf ul li {
width: 100%  ; 
}
.sw-sf li:hover {
z-index:300 ; 
}
.sw-sf li:hover {
visibility: inherit ; 
}
.sw-sf li {
float: left; 
position: relative; 
}
.sw-sf li li{
 top: 0  ; 
 left: 0; 
position: relative; 
}
.sw-sf a {
display: block; 
position: relative; 
}
.sw-sf li:hover ul ,
.sw-sf li.sfHover ul {
left: 0; 
top: 2.5em; 
z-index: 400; 
width:100%; 
}
ul.sw-sf li:hover li ul ,
ul.sw-sf li.sfHover li ul {
top: -999em; 
}
ul.sw-sf li li:hover ul ,
ul.sw-sf li li.sfHover ul {
left: 10em; 
top: 0; 
}
ul.sw-sf li li:hover li ul ,
ul.sw-sf li li.sfHover li ul {
top: -999em; 
}
ul.sw-sf li li li:hover ul ,
ul.sw-sf li li li.sfHover ul {
left: 10em; 
top: 0; 
}
#sfmenu {
position: relative; 
 border-width: 3px ;
 border-color: #17050E ;
top: 0px  ; 
left: 0px; 
}
.sf-section {
 border-color: #061C1B ;
}
.sw-sf li.sfHover li , .sw-sf li:hover li {
top:0px  ; 
left:0px  ; 
}
.sw-sf li.sfHover li.sfHover li {
top:0px ; 
left:0px ; 
}
.sw-sf a.item1 {
 padding-right: 30px ;
 padding-left: 27px ;
 font-size: 15px  ; 
 font-family: Times New Roman, Times, serif  ; 
 text-align: left  ; 
 font-weight: normal  ; 
 color: #7A7A7A  ; 
 margin-top: 20px ;
 font-style: normal ;
 text-decoration: none ;
 text-transform: none ;
 border-top-color: #F34AFF ;
 border-left-color: #F34AFF ;
 border-bottom-color: #F34AFF ;
 border-right: 0; 
 display: block; 
 white-space: nowrap; 
 position: relative; 
background-image:none ;
}
.sw-sf a.item1.last {
 border-right-color: #F34AFF ;
}
.sw-sf li.sfHover a.item1,
.sw-sf a:focus,
.sw-sf a:hover ,
.sw-sf a:active {
background-image:none ;
 color: #7A7A7A  ; 
}
.sw-sf .current a.item1{
background-image:none ;
 color: #7A7A7A  ; 
}
.sw-sf  a.item2 {
 padding-top: 9px ;
 padding-right: 29px ;
 padding-bottom: 10px ;
 padding-left: 15px ;
 font-size: 15px  ; 
 font-family: Times New Roman, Times, serif  ; 
 text-align: left  ; 
 font-weight: normal  ; 
 font-style: normal ;
 text-decoration: none ;
 text-transform: none ;
 display: block; 
 white-space: nowrap ; 
background-image:none ;
 position: relative; 
 border-top-color: #94FFB4 ;
 border-left-color: #94FFB4 ;
 border-right-color: #94FFB4 ;
 opacity:0.8; 
 filter:alpha(opacity=80) 
}
.sw-sf a.item2.last {
 border-bottom-color: #94FFB4 ;
}
.sw-sf li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf  a.item2:hover {
background-image:none ;
}
.sw-sf li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2{
background-image:none ;
}

-->
</style>
  <script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/hoverIntent.js"></script>
<script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/superfish.js"></script>
<script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/supersubs.js"></script>
  <!-- end - swMenuFree javascript and CSS links -->


    <link rel="stylesheet" href="/templates/system/css/system.css" />
    <link rel="stylesheet" href="/templates/system/css/general.css" />
<!--scroling head-->
<script src="/templates/dd_goldenline_32/js/scroling.js"></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function() {
		if($(this).scrollTop() != 0) {
			$('#toTop').fadeIn();	
		} else {
			$('#toTop').fadeOut();
		}
	});
 
	$('#toTop').click(function() {
		$('body,html').animate({scrollTop:0},800);
	});	
});
</script>
<!--end scroling-->
  <!--animacja-->
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>
<script type="text/javascript" src="/templates/dd_goldenline_32/js/s3Slider.js"></script>
<script type="text/javascript">
    $(document).ready(function() {
        $('#slider1').s3Slider({
            timeOut: 5000 
        });
    });
</script>
   </script> <!--end animacja-->
    
    
<meta name="viewport" content="initial-scale = 1.0, maximum-scale = 1.0, user-scalable = no, width = device-width" />

    <!--[if lt IE 9]><script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.css" media="screen" />
    <!--[if lte IE 7]><link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.ie7.css" media="screen" /><![endif]-->
    <link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.responsive.css" media="all" />

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link href="/css/template.css" rel="stylesheet" type="text/css">
<script>if ('undefined' != typeof jQuery) document._artxJQueryBackup = jQuery;</script>
    <script src="/templates/dd_goldenline_32/jquery.js"></script>
    <script>jQuery.noConflict();</script>

    <script src="/templates/dd_goldenline_32/script.js"></script>
    <script src="/templates/dd_goldenline_32/script.responsive.js"></script>
    <script src="/templates/dd_goldenline_32/modules.js"></script>
        <script>if (document._artxJQueryBackup) jQuery = document._artxJQueryBackup;</script>
</head>
<body>
<div id="toTop"><p>^Back To Top</p></div>
<div id="dd-main">
<header class="dd-header">
    <div class="dd-shapes"> 
  
        <div class="dd-object1981120983"></div>


<!--koniec animacja grafika-->
<div class="dd-object56742192"></div>
<div class="dd-object1293778198"></div>

    
<div class="dd-textblock dd-object1936180298">
        <div class="dd-object1936180298-text-container">
        <div class="dd-object1936180298-text"></div>
    </div>
    
</div><div class="dd-textblock dd-object650926169">
        <div class="dd-object650926169-text-container">
        <div class="dd-object650926169-text"><p></p><br /></div>
    </div>
    
</div>
            </div>

<h1 class="dd-headline">
    <a href="/"></a>
</h1>
<h2 class="dd-slogan"></h2>


<div class="dd-textblock dd-textblock-1393176558">

    
</div>

<div class="dd-textblock dd-object714367995">
    <form class="dd-search" name="Search" action="/index.php" method="post">
    <input type="text" value="" name="searchword" />
    <input type="hidden" name="task" value="search" />
<input type="hidden" name="option" value="com_search" />
<input type="submit" value="Search" name="search" class="dd-search-button" />
</form>

</div>

<nav class="dd-nav">
    

<!--swMenuFree8.3_J2.5-3.0 superfishmenu by http://www.swmenupro.com-->
<div id="sfmenu" align="left" >
<ul  id="swmenu" class="sw-sf"  > 
<li id='sf-101' class='current'> 
<a href='/' class='item1'>Home</a>
</li> 
<li id='sf-116' > 
<a href="http://www.phinfever.com/forums/" target="_blank" class="item1" >Forums</a></li> 
<li id='sf-117' > 
<a href='/index.php/draft-central' class='item1'>Draft Central</a>
</li> 
<li id='sf-118' > 
<a href='/index.php/downloads' class='item1'>Downloads</a>
</li> 
<li id='sf-119' > 
<a href='/index.php/links' class='item1'>Links</a>
</li> 
<li id='sf-120' > 
<a href='/index.php/staff' class='item1 last'>Staff</a>
</li> 
</ul><hr style="display:block;clear:left;margin:-0.66em 0;visibility:hidden;" /></div> 
<script type="text/javascript">
<!--
jQuery(document).ready(function($){
$('.sw-sf').supersubs({ 
minWidth:8,
maxWidth:80,
extraWidth:2
}).superfish({
speed:   1,autoArrows:  false
});
$('.sw-sf').parents().css('z-index','1');
$('.sw-sf').css('z-index','501');
});
//-->
</script>

<!--End swMenuFree menu module-->
     </nav>

                    
</header>
<div class="dd-sheet clearfix">
            <div class="dd-layout-wrapper">
                <div class="dd-content-layout">
                    <div class="dd-content-layout-row">
                        <div class="dd-layout-cell dd-sidebar1">
<div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Social Media</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="http://twitter.com/phinfever" target="_blank"><img src="/images/ani-twitter.gif" alt="Phinfever Twitter" width="60" height="60" /></a><a href="http://www.facebook.com/pages/Phinfever-Miami-Dolphins-Fan-Site/175907802443072" target="_blank"><img src="/images/ani-facebook.gif" alt="Phinfever Facebook" width="60" height="60" /></a><a href="/?format=feed&amp;type=rss" target="_blank"><img src="/images/ani-rssfeed.gif" alt="RSS Feed" width="60" height="60" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Draft Central</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a title="Phinfever Draft Central with Tony Simmons" href="/index.php/draft-central"><img style="display: block; margin-left: auto; margin-right: auto;" src="http://www.phinfever.com/draft/banner_draftCentral_2017.gif" alt="Phinfever Draft Central - Complete Info On Miami Dolphins' draft picks." /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Draft Info</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="/index.php/9-blog/354-2018-phinfever-mock-draft-for-the-miami-dolphins"><img src="/draft/2018_mock-Jammer01.gif" alt="Dan Jamroz Phinfever Mock 2018" width="190" height="95" /></a></p>
<p style="text-align: center;"><a href="http://www.phinfever.com/index.php/9-blog/355-56-miami-dolphin-mocks-with-comments"><img src="/draft/mockDatabase_2018-2.gif" alt="Phinfever Mock Database" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Podcasts, Interviews</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="https://itunes.apple.com/us/podcast/dolphinstalk-com-daily/id1289046573?mt=2" target="_blank"><img src="http://www.phinfever.com/images/banners/banner_DolphinsTalk-02.gif" alt="DolphinsTalk.com" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Post Game Analysis</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><img src="/images/gbu/goodBadUgly_2017.gif" alt="Phinfever, Rich Rodriguez, The Good Bad Ugly" />&nbsp; <br /><a href="/index.php/9-blog/324-dolphins-19-chargers-17-the-good-the-bad-and-the-ugly"><strong>1-0. Dolphins 19, Chargers 17<br /></strong></a><a href="/index.php/9-blog/327-dolphins-6-jets-20-the-good-the-bad-and-the-ugly"><strong>1-1. Dolphins 6, Jets 20<br /></strong></a><strong><a href="/index.php/9-blog/328-saints-20-dolphins-0-the-good-the-bad-and-the-ugly">1-2. Dolphins 0, Saints 20<br /></a><a href="/index.php/9-blog/330-titans-10-dolphins-16-the-good-the-bad-and-the-ugly">2-2. Dolphins 16, Titans 10<br /></a></strong><a href="http://www.phinfever.com/forums/viewtopic.php?f=2&amp;t=16576" target="_blank"><strong>3-2. Dolphins 20, Falcons 17<br /></strong></a><a href="/index.php/9-blog/335-jets-28-dolphins-31-the-good-the-bad-and-the-ugly"><strong>4-2. Dolphins 31, Jets 28<br /></strong></a><a href="/index.php/9-blog/337-dolphins-0-ravens-40-the-good-the-bad-and-the-ugly" target="_blank"><strong>4-3. Dolphins 0, Ravens 40<br /></strong></a><a href="http://www.phinfever.com/forums/viewtopic.php?f=2&amp;t=16653&amp;sid=a3bcc5b5d64d31a7341f6fc2d738f256"><strong>4-4. Dolphins 24, Raiders 27<br /></strong></a><a href="/index.php/9-blog/340-dolphins-21-panthers-45-the-good-the-bad-and-the-ugly"><strong>4-5. Dolphins 21, Panthers 45<br /></strong></a><a href="https://www.youtube.com/watch?v=0_uketeABA0" target="_blank"><strong>4-6. Dolphins 20, Bucs 30<br /></strong></a><a href="https://www.youtube.com/watch?v=JGWHCR-_U54" target="_blank"><strong>4-7. Dolphins 17, Patriots 35<br /></strong></a><strong><a href="https://www.youtube.com/watch?v=15jd9oYVqo8" target="_blank">5-7. Dolphins 35, Broncos 9<br /></a><a href="https://www.youtube.com/watch?v=j7RZy2B73hw" target="_blank">6-7. Dolphins 27, Patriots 20<br /></a><a href="https://www.youtube.com/watch?v=HIlk0x4GM18" target="_blank">6-8. Dolphins 16, Bills 24<br /></a></strong><a href="https://www.youtube.com/watch?v=sv-5oZ0UNqg" target="_blank"><strong>6-9. Dolphins 13, Chiefs 29<br /></strong></a><a href="https://www.youtube.com/watch?v=tZXhJgzZUWE" target="_blank"><strong>6-10. Dolphins 16, Bills 22</strong></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Phinfever FFL</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="http://www71.myfantasyleague.com/2018/home/21714#0" target="_blank"><img src="/images/banner_TRockFFL01.jpg" alt="T-Rock's Phinfever FFL 2014" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Armando Salguero</h3></div><div class="dd-blockcontent"><a class="twitter-timeline" data-theme="light" data-link-color="##f68121" data-border-color="##015778"  data-chrome="nofooter noborders "  3  href="https://twitter.com/ArmandoSalguero" data-widget-id="441264728141070337" width="200" height="350">Tweets by @ArmandoSalguero</a>

<script type="text/javascript">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Barry Jackson</h3></div><div class="dd-blockcontent"><a class="twitter-timeline" data-theme="light" data-link-color="##f68121" data-border-color="##015778"  data-chrome="nofooter noscrollbar "  3  href="https://twitter.com/flasportsbuzz" data-widget-id="624920826568159232" width="200" height="350">Tweets by @flasportsbuzz</a>

<script type="text/javascript">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Dave Hyde</h3></div><div class="dd-blockcontent"><a class="twitter-timeline" data-theme="light" data-link-color="##f68121" data-border-color="##015778"  data-chrome="nofooter noscrollbar "  3  href="https://twitter.com/davehydesports " data-widget-id="624917090848374784" width="200" height="350">Tweets by @davehydesports </a>

<script type="text/javascript">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">miamidolphins.com</h3></div><div class="dd-blockcontent"><a class="twitter-timeline" data-theme="light" data-link-color="##f68121" data-border-color="##cccccc"  data-chrome="nofooter noborders "  3  href="https://twitter.com/Miami Dolphins" data-widget-id="443867549118132224" width="200" height="600">Tweets by @Miami Dolphins</a>

<script type="text/javascript">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></div>



                        </div>

                        <div class="dd-layout-cell dd-content">
<!-- begin nostyle -->
<div class="dd-nostyle">
<!-- begin nostyle content -->
<!-- JSN IMAGESHOW FREE 4.8.1 - Theme Slider 1.1.7 --><div class="jsn-container"><div class="jsn-gallery"><div id="jsn-themeslider-skitter-knUzJ"><div style="width: 500px; height: 300px;" class="box_skitter jsn-themeslider-gallery jsn-themeslider-skitter-knUzJ">
<ul><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg" alt="001.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">001.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg" alt="002.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">002.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg" alt="003.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">003.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg" alt="004.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">004.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg" alt="005.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">005.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg" alt="006.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">006.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg" alt="007.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">007.jpg</p></div>
					 </li></ul><input type="hidden" class="cache_skitter_index" value="" /></div>
</div><script type="text/javascript">
						jsnThemeSliderjQuery(function() {
						jsnThemeSliderjQuery(document).ready(function(){
							var wrap_width = parseInt(500);
							var window_width = parseInt(jsnThemeSliderjQuery(window).width());
							if (wrap_width > window_width) {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-knUzJ').css("width", "100%");
							} else {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-knUzJ').css("width", "500px");
							}
							var oldHTML = jsnThemeSliderjQuery('#jsn-themeslider-skitter-knUzJ').html();
							var options = {"animation":"random","navigation":true,"navShowOnMouseOver":true,"dots":false,"numbers":false,"caption_title_css":"font-family: Verdana;\r\nfont-size: 12px;\r\nfont-weight: bold;\r\ntext-align: left;\r\ncolor: #E9E9E9;","caption_description_css":"font-family: Arial;\r\nfont-size: 11px;\r\nfont-weight: normal;\r\ntext-align: left;\r\ncolor: #AFAFAF;","caption_link_css":"font-family: Verdana;\r\nfont-size: 11px;\r\nfont-weight: bold;\r\ntext-align: right;\r\ncolor: #E06614;","caption_position":"bottom","caption_caption_opacity":"filter:alpha(opacity=75);opacity: 0.75;","interval":6000,"controls":false,"stop_over":true,"auto_play":true,"caption_title_show":true,"caption_description_show":true,"caption_link_show":false,"label":false,"animateNumberActive":{"backgroundColor":"#CC3333","color":"#fff"},"click_action":"no_action","open_link_in":"current_browser","skitter_class_id":"jsn-themeslider-skitter-knUzJ"};
							options.base_height = 300;
							jsnThemeSliderjQuery('.jsn-themeslider-skitter-knUzJ').skitter(options);
							jsnThemeSliderjQuery('.jsn-themeslider-skitter-knUzJ .image_main').css("max-width", "");
							var jsn_knUzJ = jsnThemeSliderjQuery(window).width();
							var cacheResize;
							jsnThemeSliderjQuery(window).resize(function (e) {
								if (jsn_knUzJ != jsnThemeSliderjQuery(window).width())
								{
									clearTimeout(cacheResize);
									cacheResize = "";
									var oldCacheIndex = jsnThemeSliderjQuery('#jsn-themeslider-skitter-knUzJ .cache_skitter_index').attr('value');
									jsnThemeSliderjQuery('#jsn-themeslider-skitter-knUzJ').html(oldHTML);
									var wrap_width = parseInt(500);
							var window_width = parseInt(jsnThemeSliderjQuery(window).width());
							if (wrap_width > window_width) {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-knUzJ').css("width", "100%");
							} else {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-knUzJ').css("width", "500px");
							}
									jsnThemeSliderjQuery('#jsn-themeslider-skitter-knUzJ .cache_skitter_index').attr('value', oldCacheIndex);
									var options = {"animation":"random","navigation":true,"navShowOnMouseOver":true,"dots":false,"numbers":false,"caption_title_css":"font-family: Verdana;\r\nfont-size: 12px;\r\nfont-weight: bold;\r\ntext-align: left;\r\ncolor: #E9E9E9;","caption_description_css":"font-family: Arial;\r\nfont-size: 11px;\r\nfont-weight: normal;\r\ntext-align: left;\r\ncolor: #AFAFAF;","caption_link_css":"font-family: Verdana;\r\nfont-size: 11px;\r\nfont-weight: bold;\r\ntext-align: right;\r\ncolor: #E06614;","caption_position":"bottom","caption_caption_opacity":"filter:alpha(opacity=75);opacity: 0.75;","interval":6000,"controls":false,"stop_over":true,"auto_play":true,"caption_title_show":true,"caption_description_show":true,"caption_link_show":false,"label":false,"animateNumberActive":{"backgroundColor":"#CC3333","color":"#fff"},"click_action":"no_action","open_link_in":"current_browser","skitter_class_id":"jsn-themeslider-skitter-knUzJ"};
									options.base_height = 300;
									cacheResize = setTimeout(function () {
										jsnThemeSliderjQuery('.jsn-themeslider-skitter-knUzJ').skitter(options);
										jsnThemeSliderjQuery('.jsn-themeslider-skitter-knUzJ .image_main').css("max-width", "");
									}, 500);
									jsn_knUzJ = jsnThemeSliderjQuery(window).width();
								}
							});
						})});
				</script><div class="jsn-themeslider-seocontent">
<p>Joomla gallery extension by <a href="http://www.joomlashine.com" title="Joomla gallery">joomlashine.com</a></p>
<div><p>2015 Dolphins Draft Picks</p><p></p><ul><li><p>001.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg</a></p></li><li><p>002.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg</a></p></li><li><p>003.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg</a></p></li><li><p>004.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg</a></p></li><li><p>005.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg</a></p></li><li><p>006.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg</a></p></li><li><p>007.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg</a></p></li></ul></div></div>
</div></div><!-- end nostyle content -->
</div>
<!-- end nostyle -->
<article class="dd-post dd-messages"><div class="dd-postcontent clearfix">
<div id="system-message-container">
</div></div></article><div class="item-page"><article class="dd-post"><div class="dd-postmetadataheader"><h2 class="dd-postheader"><a href="/index.php/9-blog/355-56-miami-dolphin-mocks-with-comments">56 Miami Dolphin Mocks with Comments</a></h2></div><div class="dd-postheadericons dd-metadata-icons"><span class="dd-postdateicon">Published: Monday, 09 April 2018 10:52</span> | <span class="dd-postauthoricon">Written by David Blake</span> | <a href="/index.php/9-blog/355-56-miami-dolphin-mocks-with-comments?tmpl=component&amp;print=1&amp;page=" title="Print" onclick="window.open(this.href,'win2','status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=yes,width=640,height=480,directories=no,location=no'); return false;" rel="nofollow"><img src="/templates/dd_goldenline_32/images/system/printButton.png" alt="Print" /></a> | <a href="/index.php/component/mailto/?tmpl=component&amp;template=dd_goldenline_32&amp;link=337306fb10ce52944e887840722836f34ab5905e" title="Email" onclick="window.open(this.href,'win2','width=400,height=350,menubar=yes,resizable=yes'); return false;"><img src="/templates/dd_goldenline_32/images/system/emailButton.png" alt="Email" /></a> | Hits: 127</div><div class="dd-postcontent clearfix"><div class="dd-article"><p>&nbsp;</p>
<p><span style="font-size: 14pt;"><a href="/draft/2018/PhinfeverMockCentral-2018_full.html" target="_blank">Open Mock in Full Screen</a></span></p>
<p>&nbsp;</p>
<p><img src="/draft/2018/2018-04-08_mock02.png" alt="" width="480" /></p>
<p><img src="/draft/2018/2018-04-08_mock01.png" alt="" width="480" height="292" /></p>
<table style="width: 100%;" border="1" cellspacing="0" cellpadding="2">
<tbody>
<tr bgcolor="#ff6600">
<td colspan="5" height="50">
<div align="center"><strong><span style="color: #ffffff; font-size: xx-large;">PHINFEVER MOCK DATABASE (56)</span></strong></div>
</td>
</tr>
<tr bgcolor="#009f9f">
<td width="10%">
<p align="center"><span style="color: #ffffff;"><strong>SITE</strong></span></p>
</td>
<td width="6%">
<p align="center"><span style="color: #ffffff;"><strong>MOCK </strong></span></p>
</td>
<td width="10%">
<p align="center"><span style="color: #ffffff;"><strong>BIO</strong></span></p>
</td>
<td width="66%">
<p align="center"><span style="color: #ffffff;"><strong>COMMENTS</strong></span></p>
</td>
<td width="8%">
<p align="center"><span style="color: #ffffff;"><strong>UPDATED</strong></span></p>
</td>
</tr>
<tr>
<td>
<p align="center"><a href="http://www.phinfever.com/" target="_blank"><strong>Phinfever Owner:<br /> David<br /> Blake</strong></a></p>
</td>
<td>
<div align="center">Minkah Fitzpatrick</div>
</td>
<td>
<div align="center">S<br /> Alabama <br /> Junior<br /> 6'1"<br /> 202 lbs<br /> 40 @ 4.50</div>
</td>
<td>
<p align="left">This is such a tough one as the Dolphins are in prime position, due to all the "good" quarterbacks in this draft, to grab a playmaking defensive player if they stand pat at #11. If the Dolphins have a chance to draft QB Baker Mayfield or QB Josh Rosen, then they may try to trade up to #6 with the Colts if either one is available there. It will be very costly, so, my hope is that they stand pat at 11 and draft linebacker or safety. They can then draft a QB in round 2 or 3. It is hard to say whom they value more as linebacker and safety are both positions of need due to some inept free agent moves. ReShad Jones and Tim McDonald are the same type of safeties, so, they have a need for a Minkah Fintzpatrick or a Derwin James at safety. Either would be the type of player who can jump in and cover a tight end which is what they really want in this draft. LBs Roquan Smith and Tremain Edmunds would be outstanding picks as well, but teams are using the nickel more than the traditional LB set. Let's not forget that our linebackers have real question marks coming into this season. To me, linebacker is a bigger need than safety, but it all depends on how Miami's draft board looks. Several mocks have QB Baker Mayfield falling to 11, so, you have that, too. It is doubtful that it happens, but the Dolphins would be crazy to not draft Mayfield if he is available at 11. If by chance that QB Mayfield, S Fitzpatrick, S James, LB Smith, and LB Edmunds are already gone, you can count on DT Vita Vea being the choice. Trading down should not be an option for the Dolphins as "The enemy of great is good".</p>
<p align="left">Round 2: Sony Michel, RB, Georgia<br /> I just can't see Coach Gase allowing GM Chris Grier to let Michel get past them if he is available. He is the type of running back that Gase loves as he is shifty and fast, very disciplined, and is a very good pass protector. The Dolphins fell behind quickly in games last year and did not have the offense to keep pace. I know what you are thinking: "Forget that, Dave. I'm going with Jammer's pick of Hayden Hurst as the Dolphins need a tight end in the worst way." That could definitely be the pick. To be honest, I really don't know the last time the Dolphins did draft a tight end that high. Ever? Maybe that is their problem. Still, I am going to stick with Michel as my pick.</p>
</td>
<td>
<div align="center">Apr 8</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.phinfever.com/index.php/9-blog/354-2018-phinfever-mock-draft-for-the-miami-dolphins" target="_blank">Phinfever Draft Analyst:<br /> Dan Jamroz</a></strong></p>
</td>
<td>
<div align="center">Minkah Fitzpatrick</div>
</td>
<td>
<div align="center">S<br /> Alabama <br /> Junior<br /> 6'1"<br /> 202 lbs<br /> 40 @ 4.50</div>
</td>
<td>
<div align="left">
<p align="left">Word on the street is that Minkah Fitzpatrick holds more value with draftnicks than with the actual scouting community. Like we've seen in previous years, there is always a sure bet guy who suddenly falls out of the top 10. Miami is rumored to LOVE him and he is exactly what Gase and Burke are talking about in that hybrid situation. He has the flexibility to play cornerback as well but his responsibility would be the slot and taking out bigger tight ends.</p>
<p align="left">Round 2 - Hayden Hurst TE South Carolina<br /> Round 3 - Luke Falk QB Washington State<br /> Round 4 - Dorian O'Daniel LB Clemson<br /> Round 4 - Tavarus McFadden CB Florida State<br /> Round 6 - Justin Jones DT North Carolina State<br /> Round 7 - Kalen Ballage RB Arizona State<br /> Round 7 - KC McDermott OT/OG Miami</p>
</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td colspan="5">&nbsp;</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://athlonsports.com/nfl/2018-nfl-mock-draft-first-round-predictions-updated-post-scouting-combine" target="_blank">Athlon<br /> Sports</a></strong></p>
</td>
<td>
<div align="center">Josh Rosen</div>
</td>
<td>
<div align="center">QB<br /> UCLA <br /> Senior<br /> 6'4"<br /> 218 lbs<br /> 40 @ 4.95</div>
</td>
<td>
<div align="left">Maybe Rosen starts to slip or maybe Miami goes up and gets him but the UCLA quarterback seems like he'd be a perfect fit in Adam Gase's offense and he doesn't hamper the team's ability to win in the short term or over the long haul. Don't buy into all the off-the-field chatter surrounding Rosen, as he has the chance to be the best signal-caller in this class.</div>
</td>
<td>
<div align="center">Mar 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://bleacherreport.com/articles/2768875-2018-nfl-mock-draft-1st-round-predictions-and-rising-impact-prospects" target="_blank">Bleacher<br /> Report</a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">(No comment given.)</div>
</td>
<td>
<div align="center">Apr 7</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://breakingfootball.com/category/nfl-draft/mock-drafts/" target="_blank">Breaking Football </a></strong></p>
</td>
<td>
<div align="center">Roquan Smith</div>
</td>
<td>
<div align="center">LB<br /> Georgia<br /> Junior<br /> 6'1"<br /> 225 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">The linebacker spot has been a problem for the Dolphins over the past few season. Kilo Alonzo has struggled at times, Lawrence Timmons was a bust free agent signing, and Raekwon McMillan is coming off a torn ACL. Roquan Smith would give the Dolphins an impact player who can do it all from day one</div>
</td>
<td>
<div align="center">Mar 31</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.cbssports.com/nfl/draft/mock-draft/expert/chris-trapasso/" target="_blank">CBS<br /> Sportsline<br /> Chris Trapasso</a></strong></p>
</td>
<td>
<div align="center">Derwin James</div>
</td>
<td>
<div align="center">S<br /> Florida St<br /> Sophmore<br /> 6'3"<br /> 215 lbs<br /> 40 @ 4.55</div>
</td>
<td>
<div align="left">Reshad Jones is one of the most underrated defensive backs in football, but he's 30 and the Dolphins need more talent in their secondary. James would be a nice pick here.</div>
</td>
<td>
<div align="center">Apr 2</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.cbssports.com/nfl/draft/mock-draft" target="_blank">CBS<br /> Sportsline<br /> Jared Dubin</a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">(No comment given.)</div>
</td>
<td>
<div align="center">Apr 5</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.cbssports.com/nfl/draft/mock-draft" target="_blank">CBS<br /> Sportsline<br /> Pete Prisco</a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">This would be a nice replacement for Ndamukong Suh -- and a lot cheaper. He is a more athletic player than Haloti Ngata, who many compare him to in evaluations.</div>
</td>
<td>
<div align="center">Apr 5</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.cbssports.com/nfl/draft/mock-draft/expert/rj-white/" target="_blank">CBS<br /> Sportsline<br /> RJ White</a></strong></p>
</td>
<td>
<div align="center">Roquan Smith</div>
</td>
<td>
<div align="center">ILB<br /> Georgia <br /> Junior<br /> 6'1"<br /> 225 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">The Dolphins have been showing interest in Smith, one of the draft's top linebackers. He'd be the long-term stud the team needs next to Raekwon McMillan, and the Dolphins could make him the immediate starter at WILL and look to trade Kiko Alonso to another team where he'd be a better fit. They can also think about getting out from Alonso's deal next offseason if nothing else.</div>
</td>
<td>
<div align="center">Mar 29</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.cbssports.com/nfl/draft/news/2018-nfl-mock-draft-two-trades-in-top-five-giants-go-linebacker-after-moving-down/" target="_blank">CBS<br /> Sportsline<br /> Tom Fornelli</a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">The Dolphins are another team that could trade up for a QB, but in this mock I have them drafting a replacement for Ndamukong Suh.</div>
</td>
<td>
<div align="center">Apr 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.cbssports.com/nfl/draft/mock-draft/expert/will-brinson/" target="_blank">CBS<br /> Sportsline<br /> Will Brinson</a></strong></p>
</td>
<td>
<div align="center">Denzel Ward</div>
</td>
<td>
<div align="center">CB<br /> Ohio St<br /> Senior<br /> 5'10"<br /> 191 lbs<br /> 40 @ 4.40</div>
</td>
<td>
<div align="left">The Dolphins appear resigned to the fact they won't be getting a quarterback in this draft class, which means they're simply taking the best player available.</div>
</td>
<td>
<div align="center">Apr 3</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.cbssports.com/nfl/draft/mock-draft/expert/ryan-wilson/" target="_blank">CBS<br /> Sportsline<br /> Ryan Wilson</a></strong></p>
</td>
<td>
<div align="center">Roquan Smith</div>
</td>
<td>
<div align="center">ILB<br /> Georgia <br /> Junior<br /> 6'1"<br /> 225 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">A confluence of events -- most of them quarterback-related -- have Smith falling to the Dolphins who, incidentally, would've loved the opportunity to draft a quarterback. But Smith is a fantastic consolation prize and saves Miami from reaching for a passer, especially since the team has serious needs at linebacker, especially after Lawrence Timmons' one and only hugely disappointing season in South Florida.</div>
</td>
<td>
<div align="center">Apr 3</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.freep.com/picture-gallery/sports/nfl/lions/2018/03/20/dave-birketts-2018-nfl-mock-draft-20/33118783/" target="_blank">Detroit Free Press</a></strong></p>
</td>
<td>
<div align="center">Da'Ron Payne</div>
</td>
<td>
<div align="center">DT<br /> Alabama <br /> Senior<br /> 6'2"<br /> 308 lbs<br /> 40 @ 5.40-</div>
</td>
<td>
<div align="left">No remaining quarterback is worth the 11th pick, so the Dolphins go fishing for an Ndamukong Suh replacement.</div>
</td>
<td>
<div align="center">Mar 20</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.draftblaster.com/nfl-mock-draft-2018/" target="_blank">Draft Blaster</a></strong></p>
</td>
<td>
<div align="center">Derwin James</div>
</td>
<td>
<div align="center">S<br /> Florida St<br /> Sophmore<br /> 6'3"<br /> 215 lbs<br /> 40 @ 4.55</div>
</td>
<td>
<div align="left">The Dolphins need to hope and pray that Tannehill can come back next year healthy and stay healthy. His contract is not actually very troublesome if they decide to move on after next year, but he really needs to stay healthy. The Dolphins are mired in a bit of a mess with some poor free agent moves, and are aging quickly at several key positions. On defense they are in need of some young pieces and should keep an open mind at this point in the draft to taking talent over immediate need.</div>
</td>
<td>
<div align="center">Apr 7</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.draftking.com/mock/2018/" target="_blank">Draft<br /> King</a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">Vea's performance at the Combine was exceptional, with 41 reps of the 225-pound bench press and a remarkable 5.10 40-yard dash time. Miami parted ways with DT Ndamukong Suh this off-season, and Vea would be a great pickup at this spot for the Dolphins.</div>
</td>
<td>
<div align="center">Mar 23</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.draftseason.com/lupagus-2018-nfl-mock-draft/" target="_blank">Draft<br /> Season<br /> Lupagus</a></strong></p>
</td>
<td>
<div align="center">Josh Allen</div>
</td>
<td>
<div align="center">QB<br /> Wyoming<br /> Junior<br /> 6'5"<br /> 240 lbs<br /> 40 @ 4.80</div>
</td>
<td>
<div align="left">The Phins stay put and get the QB they were hoping for. Allen has accuracy issues, but his rocket arm will be well received.</div>
</td>
<td>
<div align="center">Mar 23</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.draftseason.com/2018-ultimate-nfl-mock-draft/" target="_blank">Draft<br /> Season<br /> ULTIMATE</a></strong></p>
</td>
<td>
<div align="center">Josh Allen</div>
</td>
<td>
<div align="center">QB<br /> Wyoming<br /> Junior<br /> 6'5"<br /> 240 lbs<br /> 40 @ 4.80</div>
</td>
<td>
<div align="left">Not overly shabby to get a top quarterback at pick 11. Allen might have the most untapped potential who given time could end up being a star.</div>
</td>
<td>
<div align="center">Mar 12</div>
</td>
</tr>
<tr>
<td>
<div align="center">
<p><strong><a href="http://www.drafttek.com/2018-NFL-Mock-Draft-Round1.asp" target="_blank">Draft<br /> Tek</a></strong></p>
</div>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">
<p>Two areas of grave concern exist on the Dolphins roster. Using a first round pick on a linebacker is an uneasy proposition given the direction of the NFL, and the strength of this tight end class exists on day-two. Despite the national pundits still holding onto the idea that a quarterback is in play, Miami has made it clear that the position is already buttoned up with Ryan Tannehill. With Minkah Fitzpatrick and Derwin James off the board, the Dolphins look to fill the hole created by Ndamukong Suh's release.</p>
<p>Vita Vea is a mountain of a man with elite athleticism and pass-rush ability. He would enter camp as the clear-cut favorite for DT1 and provide the Dolphins with an immediate impact player. Perhaps his best highlight from the 2017 season, Vea showed off his movement skills covering a punt in the Fiesta Bowl. Pairing Vea with Jordan Phillips, Davon Godchaux and Vincent Taylor would give the Dolphins a young, exciting group of interior defensive linemen.</p>
</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://draftwire.usatoday.com/2018/04/04/2018-nfl-mock-draft-latest-3-round-projections-with-trades/" target="_blank">Draft<br /> Wire </a></strong></p>
</td>
<td>
<div align="center">Minkah Fitzpatrick</div>
</td>
<td>
<div align="center">S<br /> Alabama <br /> Junior<br /> 6'1"<br /> 202 lbs<br /> 40 @ 4.50</div>
</td>
<td>
<div align="left">
<p>There are bigger needs for the Dolphins elsewhere, but this is about value. Fitzpatrick is one of the top all-around prospects in this class, and his versatility gives him the ability to make an immediate impact just about anywhere on the field for Miami.</p>
<p>42. Miami Dolphins | Dallas Goedert | TE | South Dakota State<br /> 73. Miami Dolphins | Braden Smith | OL | Auburn</p>
</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.espn.com/nfl/draft2018/insider/story/_/id/22917443/nfl-mock-draft-2018-30-mel-kiper-first-round-pick-rankings-draft-order-32-picks" target="_blank">ESPN INSIDER<br /> Mel<br /> Kiper </a></strong><br /> *</p>
</td>
<td>
<div align="center">Derwin James</div>
</td>
<td>
<div align="center">S<br /> Florida St<br /> Sophmore<br /> 6'3"<br /> 215 lbs<br /> 40 @ 4.55</div>
</td>
<td>
<div align="left">James is back in the discussion for the top 10 after he ran a 4.47 40-yard dash and showed off a 40-inch vertical at the combine. He has rare athleticism for a 6-foot-2 safety, though his 2017 tape was inconsistent after he returned from a knee injury that caused him to miss most of the previous season. At his best, James is an enforcer in the mold of Kam Chancellor -- he's not afraid to bring the wood. He can be a versatile defender who plays in the box and also covers the deep middle of the field. The Dolphins have arguably lost more talent this offseason than any other team, and they have needs all across their roster.</div>
</td>
<td>
<div align="center">Mar 28</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.espn.com/nfl/draft2018/insider/story/_/id/23008441/nfl-two-round-2018-mock-draft-mel-kiper-todd-mcshay-dueling-first-second-round-pick-rankings-draft-order-32-picks" target="_blank">ESPN INSIDER<br /> Todd<br /> McShay </a></strong><br /> *</p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">Trade up to pick #6 with Colts. If Denver passes on Mayfield, I think Miami pounces and moves up to get him. Moving up wouldn't bankrupt Miami from a draft-capital standpoint. The Dolphins like Ryan Tannehill when he's healthy, but they can't trust him to stay on the field.</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://fansided.com/2018/04/06/2018-nfl-mock-draft-browns-patriots-raiders-steelers-josh-rosen/" target="_blank">FanSided<br /> Joe Romano</a></strong></p>
</td>
<td>
<div align="center">Minkah Fitzpatrick</div>
</td>
<td>
<div align="center">S<br /> Alabama <br /> Junior<br /> 6'1"<br /> 202 lbs<br /> 40 @ 4.50</div>
</td>
<td>
<div align="left">(No comment given.)</div>
</td>
<td>
<div align="center">Apr 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://footballfanspot.com/2018/04/07/2018-nfl-mock-draft/" target="_blank">Football<br /> Fan<br /> Spot</a></strong></p>
</td>
<td>
<div align="center">Lamar Jackson</div>
</td>
<td>
<div align="center">QB<br /> Louisville<br /> Senior<br /> 6'3"<br /> 211 lbs<br /> 40 @ 4.40</div>
</td>
<td>
<div align="left">
<p>Lamar Jackson's evaluations are all over the place, as he's one of the more polarizing prospects in the draft, but it only takes one team to take you in the first round and if a quarterback needy team has a first round grade on him, they'll pull the trigger. Multiple teams had day 2 grades on Deshaun Watson last year but that didn't stop the Texans from trading up to get him at 12. Lamar Jackson should go in that range as well. The Cardinals and Ravens are options and someone could trade up for him as well, but the Dolphins should be able to get him at 11 if they like him.</p>
<p>Ryan Tannehill isn't a terrible starting quarterback, but he hasn't played since December 2016 with knee problems and is owed non-guaranteed salaries of 18.75 million and 19.5 million in 2019 and 2020, so the Dolphins could use a cheap young quarterback behind him on the depth chart. Miami would be a good spot for Jackson as he wouldn't need to play immediately and could spend a year on the bench developing. The Dolphins could also design some gadget plays for him as a rookie, to make use of his unique skill set while he develops as a passer.</p>
</div>
</td>
<td>
<div align="center">Apr 7</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://ftw.usatoday.com/2018/03/2018-nfl-mock-draft-trades-combine-josh-allen-browns-broncos-josh-rosen-saquon-barkley" target="_blank">For The Win<br /> USA Today <br /> </a></strong></p>
</td>
<td>
<div align="center">Tremaine Edmunds</div>
</td>
<td>
<div align="center">OLB<br /> Virginia Tech<br /> Senior<br /> 6'5"<br /> 250 lbs<br /> 40 @ 4.80</div>
</td>
<td>
<div align="left">Reports are suggesting Miami could go quarterback here, but I think they have more faith in Ryan Tannehill than we're being led to believe. The Dolphins put their faith in Tannehill and finally address the linebacker position, which has been a need for years now.</div>
</td>
<td>
<div align="center">Mar 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.fueledbysports.com/2018-nfl-mock-draft/">Fueled By Sports</a></strong></p>
</td>
<td>
<div align="center">Josh Rosen</div>
</td>
<td>
<div align="center">QB<br /> UCLA<br /> Senior<br /> 6'4"<br /> 218 lbs<br /> 40 @ 4.95</div>
</td>
<td>
<div align="left">Round 2: Holton Hill / CB - Texas</div>
</td>
<td>
<div align="center">Apr 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.latimes.com/mc-spt-nfl-mock-draft-20180402-story.html" target="_blank">LA Times<br /> Sam Farmer </a></strong></p>
</td>
<td>
<div align="center">Derwin James</div>
</td>
<td>
<div align="center">S<br /> Florida St<br /> Sophmore<br /> 6'3"<br /> 215 lbs<br /> 40 @ 4.55</div>
</td>
<td>
<div align="left">The Dolphins, who have sledgehammer safeties in Reshad Jones and T.J. McDonald, could use a burner like James who has the speed to blanket not just tight ends but receivers.</div>
</td>
<td>
<div align="center">Apr 1</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.nationalfootballpost.com/2018-two-round-nfl-mock-draft-2-0/" target="_blank">National<br /> Football Post<br /> </a></strong></p>
</td>
<td>
<div align="center">Denzel Ward</div>
</td>
<td>
<div align="center">CB<br /> Ohio St<br /> Senior<br /> 5'10"<br /> 191 lbs<br /> 40 @ 4.40</div>
</td>
<td>
<div align="left">The Phins' pass defense placed right on the Mendoza line in 2017 and, despite Xavien Howard showing strong signs of encouragement, more is needed – a particularly prudent option with Vea off the board. Ward is a productive and complete cornerback.</div>
</td>
<td>
<div align="center">Mar 28</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.newsday.com/sports/football/nfl-mock-draft-2018-1.15744929" target="_blank">Newsday<br /> </a></strong></p>
</td>
<td>
<div align="center">Roquan Smith</div>
</td>
<td>
<div align="center">ILB<br /> Georgia <br /> Junior<br /> 6'1"<br /> 225 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">The Dolphins wasted little time upgrading their defense after reportedly trading for Rams pass-rusher Robert Quinn, but they still need help at linebacker. Roquan Smith was the leader of Georgia's defense and is the one of the best off-ball linebackers in this class. He's a do-it-all player with excellent sideline-to-sideline range, instincts, power and tackling ability.</div>
</td>
<td>
<div align="center">Mar 23</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.nfl.com/draft/2018/mock-drafts" target="_blank">NFL.COM<br /> Chad<br /> Rueter<br /> </a></strong></p>
</td>
<td>
<div align="center">Tremaine Edmunds</div>
</td>
<td>
<div align="center">OLB<br /> Virginia Tech<br /> Senior<br /> 6'5"<br /> 250 lbs<br /> 40 @ 4.80</div>
</td>
<td>
<div align="left">
<p>Edmunds is an absolute stud who would be picked in the top five or six spots of many drafts. He goes a little lower here due to the early QB run.</p>
<p>42. Dolphins: Justin Reid, S, Stanford<br /> 73. Dolphins: Joseph Noteboom, OT, TCU<br /> 123. Dolphins: Mark Walton, RB, Miami<br /> 131. Dolphins: Deadrin Senat, DT, South Florida</p>
</div>
</td>
<td>
<div align="center">Apr 5</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.nfl.com/draft/2018/mock-drafts" target="_blank">NFL.COM<br /> Charley<br /> Casserly</a></strong><strong><a href="http://www.nfl.com/draft/2012/mock-drafts" target="_blank"><br /> </a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Junior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">With the division-rival Jets and Bills picking quarterbacks in the top five, Miami keeps pace by adding Mayfield.</div>
</td>
<td>
<div align="center">Apr 3</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.draftcountdown.com/mock-draft/2017-mock-draft/" target="_blank">NFL<br /> Draft<br /> Countdown</a></strong></p>
</td>
<td>
<div align="center">Tremaine Edmunds</div>
</td>
<td>
<div align="center">OLB<br /> Virginia Tech<br /> Senior<br /> 6'5"<br /> 250 lbs<br /> 40 @ 4.80</div>
</td>
<td>
<div align="left">
<p>The Phins have two of the three spots in their linebacking corps settled with Kiko Alonso and Raewkon McMillan. This choice could provide the final and most dynamic piece of the puzzle, whether it's Georgia's Roquan Smith or Edmunds.</p>
<p>Edmunds has a knack for the big play, notching an eye-popping 32.5 tackles behind the line of scrimmage the past two seasons. Not to mention 10.0 sacks as a pass rusher / blitzer. A fast, athletic 'backer with a large frame as well as excellent movement skills and range, Edmunds is one of the most versatile front seven prospects in this class. What's even scarier is he won't turn 20-years-old until after the draft and is only going to get better.</p>
<p>There is a distinct possibility that both Smith and Edmunds will already be off the board. In that scenario Miami could turn their attention to the offensive line, where they continue to have issues and Ja'Wuan James could be sent packing as a cap casualty.</p>
<p>Team Needs: OLB | RB | TE</p>
</div>
</td>
<td>
<div align="center">Feb 21</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.nfldraftgeek.com/2018-nfl-mock-draft/" target="_blank">NFL<br /> Draft<br /> Geek</a></strong></p>
</td>
<td>
<div align="center">Tremaine Edmunds</div>
</td>
<td>
<div align="center">OLB<br /> Virginia Tech<br /> Senior<br /> 6'5"<br /> 250 lbs<br /> 40 @ 4.80</div>
</td>
<td>
<div align="left">(No comment given.)</div>
</td>
<td>
<div align="center">Apr 3</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://dailydolphin.blog.palmbeachpost.com/2018/04/03/2018-nfl-mock-draft-palm-beach-posts-joe-schad-version-1-0/" target="_blank">Palm Beach Post<br /> Joe Schad </a></strong></p>
</td>
<td>
<div align="center">Roquan Smith</div>
</td>
<td>
<div align="center">ILB<br /> Georgia <br /> Junior<br /> 6'1"<br /> 225 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">
<p>All I know is, quarterbacks are always drafted higher than we think. And running backs and safeties have a tendency to slide.</p>
<p>All I know is, the Dolphins have a need at: linebacker, defensive tackle, quarterback, running back and tight end.</p>
<p>All I know is, I actually correctly guessed Charles Harris to the Dolphins in my first mock draft last year. That does not mean I will correctly predict anything this time. So don't bet on it.</p>
<p>But I might put the positional odds something like this: linebacker (50 percent), defensive tackle (25 percent), quarterback (15 percent), running back (10 percent). I just made that up on the fly. But I'm sure Miami has sketched out every possible scenario.</p>
<p>Oh, Baker, Oh Baker, my Baker, come to My Field… (Unless, you know, you're already taken…)</p>
<p>5. Denver Broncos: Baker Mayfield, QB, Oklahoma<br /> 7. Tampa Bay Bucs: Minkah Fitzpatrick, DB, Alabama<br /> 9. San Francisco 49ers: Derwin James, S, Florida State<br /> 10. Oakland Raiders: Denzel Ward, CB, Ohio State<br /> 11. Miami Dolphins: Roquan Smith, LB, Georgia<br /> 12. Buffalo Bills: Tremaine Edmunds, LB, Virginia Tech<br /> 13. Washington Redskins: Vita Vea, DT, Washington</p>
</div>
</td>
<td>
<div align="center">Apr 3</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://phinphanatic.com/2018/04/03/not-far-away-miami-dolphins-mock-draft/" target="_blank">Phinphanatic</a></strong></p>
</td>
<td>
<div align="center">Derwin James</div>
</td>
<td>
<div align="center">S<br /> Florida St<br /> Sophmore<br /> 6'3"<br /> 215 lbs<br /> 40 @ 4.55</div>
</td>
<td>
<div align="left">
<p>In my eyes, there will be run of 4 QBs in the top 5 picks, this actually benefits the Dolphins to obtain a legit Defensive player. Edmunds has been my pick since the beginning, but with all the QBs now gone, I doubt that he makes it past the 49ers (issues with Ruben Foster). Whomever loses out on Edmunds – will get Smith (Bears or Oakland).</p>
<p>Here is the thing – during the GM meetings, Gase specifically called out his Safeties and their lack of game play. I'm not saying that is the main reason, but when the Dolphins lead the league in yards obtained from an opposing Tight End –they need to do something. James is the next coming of Sean Taylor. He plays with a fire that I haven't seen in a while and would automatically increase the Dolphins presence on the back-end.</p>
<p>Previous selection – Tremaine Edmunds LB</p>
<p>2nd round - 42nd overall - Mike Gesicki - TE - Penn State<br /> 3rd round - 70th overall - Kemoko Turary - OLB - Rutgers<br /> 4th round - 104th overall - Kendrick Norton - DT - Miami<br /> 4th round - 131st overall - Troy Fumagalli - TE - Wisconsin<br /> 6th round - 195st overall - DJ Reed - CB - Kansas State<br /> 7th round - 199th overall - Logan Woodside - QB - Toledo<br /> 7th round - 203rd overall - Ito Smith - RB - Southern Miss</p>
</div>
</td>
<td>
<div align="center">Apr 3</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://twitter.com/MattyInfante/status/982413982769303553" target="_blank">Phinsider<br /> Matty<br /> Infante </a></strong></p>
</td>
<td>
<div align="center">Minkah Fitzpatrick</div>
</td>
<td>
<div align="center">S<br /> Alabama <br /> Junior<br /> 6'1"<br /> 202 lbs<br /> 40 @ 4.50</div>
</td>
<td>
<div align="left">I am pretty confident that Minkah Fitzpatrick is the top defensive player on Miami's board. But...I only think the Dolphins would trade up for Minkah if all 4 QBs were off the board. Would lower the price of moving up.</div>
</td>
<td>
<div align="center">Apr 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://twitter.com/CannataNFL/status/980180472448868352" target="_blank">Phinsider<br /> Radio<br /> Twitter Poll</a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">1- CLE - QB Sam Darnold <br /> 2- NYG - RB Saquon Barkley <br /> 3- NYJ - QB Josh Rosen <br /> 4- CLE - DE Bradley Chubb <br /> 5- DEN - QB Josh Allen <br /> 6- IND - G Quenton Nelson <br /> 7- TB - CB/S Minkah Fitzpatrick <br /> 8- CHI - LB Tremaine Edmunds <br /> 9- SF - CB Denzel Ward <br /> 10- OAK - LB Roquan Smith<br /> 11- MIA - QB Baker Mayfield</div>
</td>
<td>
<div align="center">Apr 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.profootballdraftnetwork.com/articles/latest-articles/475-march-25th-2018-nfl-mock-draft.html" target="_blank">Pro Football Draft Network</a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">Ndamukong Suh has moved on. The Dolphins have a number of needs and stopping the run is one of them. Vea is massive, powerful and surprisingly quick. He has too much potential for Miami to pass on him.</div>
</td>
<td>
<div align="center">Mar 25</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.profootballfocus.com/news/draft-pff-nfl-mock-draft-4" target="_blank">Pro<br /> Football<br /> Focus<br /> Steve Palazzolo</a> </strong></p>
</td>
<td>
<div align="center">Roquan Smith</div>
</td>
<td>
<div align="center">ILB<br /> Georgia <br /> Junior<br /> 6'1"<br /> 225 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">Seemingly always in need of a chase-and-run linebacker, the Dolphins add the draft's best in Smith who is a three-down playmaker. He has excellent range and closing speed in coverage and he always finds the ball in the run game. Most importantly, Smith finishes the play when he gets there as he missed only 18 tackles on 249 career attempts.</div>
</td>
<td>
<div align="center">Apr 3</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.profootballweekly.com/lists/2018/04/05/69656334/index.xml" target="_blank">Pro Football Weekly<br /> Bob LeGere</a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">Plug-and-play replacement for Ndamukong Suh at a much cheaper price. Should make everyone on a mediocre defense better.</div>
</td>
<td>
<div align="center">Apr 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.profootballweekly.com/lists/2018/04/05/69656334/index.xml" target="_blank">Pro Football Weekly<br /> Eric Edholm</a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">For all the reasons listed above, I think the Dolphins would need to move up for Baker. Teams now more than ever are willing to deal next year's first to go up and get a quarterback. What it hurts in lost draft capital, it makes up for in financial flexibility, although that doesn't apply to the Dolphins, who manage their books like a South Beach gentleman's club that's in deep with the shylocks.<br /> <br /> Ryan Tannehill converted some of his 2018 salary into a bonus, which, translated, means he's not going anywhere anytime soon. But hey, at least they have Danny Amendola!</div>
</td>
<td>
<div align="center">Apr 6</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.rotoworld.com/articles/cfb/78854/344/mock-drafts" target="_blank">RotoWorld </a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">Cutting Suh does not mean the Dolphins don't value defensive tackles. The price tag is totally different here, and if Mayfield, linebackers and Derwin James are off the board, Vea makes sense. He will make any linebacker who runs behind him better.</div>
</td>
<td>
<div align="center">Mar 30</div>
</td>
</tr>
<tr>
<td>
<div align="center"><strong><a href="https://www.sbnation.com/nfl-mock-draft/2018/3/26/17147934/nfl-mock-draft-2018-quarterbacks-browns-giants-jets-broncos" target="_blank">SB Nation<br /> Adam Stites </a></strong></div>
</td>
<td>
<div align="center">Tremaine Edmunds</div>
</td>
<td>
<div align="center">OLB<br /> Virginia Tech<br /> Senior<br /> 6'5"<br /> 250 lbs<br /> 40 @ 4.80</div>
</td>
<td>
<div align="left">Linebacker was an issue for the Dolphins in 2017, but the team has second-round pick Raekwon McMillan ready to step in after missing his rookie year with an ACL tear. But there's still a hole at the position after the release of Lawrence Timmons. In Edmunds, Miami can pair a 20-year-old linebacker with 22-year-old McMillan and potentially be set at the position for many years to come.</div>
</td>
<td>
<div align="center">Mar 26</div>
</td>
</tr>
<tr>
<td>
<div align="center"><strong><a href="https://www.sbnation.com/2018/4/2/17187380/2018-nfl-mock-draft-quenton-nelson-bradley-chubb-sam-darnold-josh-rosen" target="_blank">SB Nation<br /> Dan Kadar</a></strong></div>
</td>
<td>
<div align="center">Derwin James</div>
</td>
<td>
<div align="center">S<br /> Florida St<br /> Sophmore<br /> 6'3"<br /> 215 lbs<br /> 40 @ 4.55</div>
</td>
<td>
<div align="left">If the Dolphins don't take a quarterback here, they need to add a playmaker on defense. In Miami, James would be a linebacker, a role he basically played at Florida State last season.</div>
</td>
<td>
<div align="center">Apr 2</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.seattlepi.com/sports/slideshow/John-McClain-s-and-Aaron-Wilson-s-2018-NFL-mock-180003.php" target="_blank">Seattle Post Intelligencer<br /> McClain </a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">(No comment given.)</div>
</td>
<td>
<div align="center">Mar 30</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.seattlepi.com/sports/slideshow/John-McClain-s-and-Aaron-Wilson-s-2018-NFL-mock-180003.php" target="_blank">Seattle Post Intelligencer<br /> Wilson </a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">(No comment given.)</div>
</td>
<td>
<div align="center">Mar 30</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.seccountry.com/sec/nfl-mock-draft-2018-first-round-projections-top-players-order-for-the-2018-nfl-draft-april-7" target="_blank">SEC Country</a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">The Dolphins appear to be enamored with the Oklahoma star, and if he falls to 11, there's an excellent chance Miami and coach Adam Gase pounce on the Heisman Trophy winner.</div>
</td>
<td>
<div align="center">Apr 7</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.si.com/nfl/2018/03/21/mock-draft-sam-darnold-browns-bills-trade-giants-josh-allen-broncos-trade-browns-baker-mayfield" target="_blank">Sports<br /> Illustrated<br /> Albert Breer</a></strong></p>
</td>
<td>
<div align="center">Da'Ron Payne</div>
</td>
<td>
<div align="center">DT<br /> Alabama <br /> Senior<br /> 6'2"<br /> 308 lbs<br /> 40 @ 5.40-</div>
</td>
<td>
<div align="left">I flirted with putting Marcus Davenport here, but in the end, with Ndamukong Suh gone, Miami needs help on the interior more. Payne is a safe pick in this area.</div>
</td>
<td>
<div align="center">Mar 21</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.star-telegram.com/sports/nfl/dallas-cowboys/article207798234.html" target="_blank">Star Telegram</a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">
<p>Ndamukong Suh is gone. Enter Vea, a massive run-stuffing DT.</p>
</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.sun-sentinel.com/sports/sd-sp-nfl-mock-draft-2018-three-rounds-20180404-story.html" target="_blank">Sun Sentinel<br /> Eddie Brown</a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">There's a lot of smoke building around Mayfield and Dolphins head coach Adam Gase's budding bromance. The comparisons to Drew Brees make sense. If the Heisman winner were three or four inches taller, he'd likely be the top overall pick. Top needs: LB, DB, TE, QB</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.sun-sentinel.com/sports/sd-sp-nfl-mock-draft-2018-three-rounds-20180404-story.html" target="_blank">Sun Sentinel<br /> Omar Kelly</a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">Ryan Tannehill has been a middle of the pack quarterback for the past six years, and he's never had to compete for his starting spot. Insert Mayfield, whose personality matches coach Adam Gase's, and the stakes will get raised for everyone. Top needs: TE, OLB, DT, QB</div>
</td>
<td>
<div align="center">Mar 28</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://www.sportingnews.com/nfl/draft/2018/mock-draft/round/1" target="_blank">The<br /> Sporting News (TSN)</a></strong></p>
</td>
<td>
<div align="center">Vita Vea</div>
</td>
<td>
<div align="center">DT<br /> Washington <br /> Senior<br /> 6'5"<br /> 340 lbs<br /> 40 @ 5.35</div>
</td>
<td>
<div align="left">The Dolphins could go in many directions defensively, but the release of Ndamukong Suh makes tackle a monster need and lines up perfectly with Vea's value. He's an explosive player who can be a fixture in Miami's line rotation for years.</div>
</td>
<td>
<div align="center">Apr 1</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.usatoday.com/story/sports/nfl/draft/2018/04/04/nfl-mock-draft-2018-brandin-cooks-sam-darnold/484267002/" target="_blank">USA<br /> Today </a></strong></p>
</td>
<td>
<div align="center">Roquan Smith</div>
</td>
<td>
<div align="center">ILB<br /> Georgia <br /> Junior<br /> 6'1"<br /> 225 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">Miami's defense was merely average with Ndamukong Suh, which speaks volumes. Last year's linebackers didn't prove very effective despite the benefit of lining up behind Suh and the double teams he commanded. Hence, a strong case to be made for a guy like Smith, who's far more capable of making plays on his own while bringing a nice streak of leadership.</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="http://walterfootball.com/draft2018.php" target="_blank">Walters<br /> Footbal<br /> Matt McGuire</a></strong></p>
</td>
<td>
<div align="center">Baker<br /> Mayfield</div>
</td>
<td>
<div align="center">QB<br /> Oklahoma <br /> Senior<br /> 6'1"<br /> 220 lbs<br /> 40 @ 4.65</div>
</td>
<td>
<div align="left">
<p>There's enough interest for Baker Mayfield that if he isn't taken in the top six, one team will trade up for him. I had the Saints doing so in a recent update, and now I have the Dolphins opting to pull the trigger in this version.</p>
<p>The Dolphins have been linked to Mayfield, and reports indicate that they are ready to move on from Ryan Tannehill as their quarterback. Perhaps they'd move up in a trade of some sort, much like the Bills.</p>
</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://sports.yahoo.com/nfl-mock-draft-will-patriots-take-advantage-extra-first-round-pick-194311276.html" target="_blank">Yahoo! <br /> Cover32</a></strong></p>
</td>
<td>
<div align="center">Da'Ron Payne</div>
</td>
<td>
<div align="center">DT<br /> Alabama <br /> Senior<br /> 6'2"<br /> 308 lbs<br /> 40 @ 5.40-</div>
</td>
<td>
<div align="left">Speaking of Suh, the Dolphins now have a giant fresh void in the middle of their defensive line. Payne is a run-stuffer with impressive athleticism and play-making ability (remember his interception and touchdown catch against Clemson in the Sugar Bowl?). The Dolphins would be happy to take him here.</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
<tr>
<td>
<p align="center"><strong><a href="https://www.yardbarker.com/nfl/articles/two_round_nfl_mock_draft/s1__26091200" target="_blank">Yard<br /> Barker </a></strong></p>
</td>
<td>
<div align="center">Tremaine Edmunds</div>
</td>
<td>
<div align="center">OLB<br /> Virginia Tech<br /> Senior<br /> 6'5"<br /> 250 lbs<br /> 40 @ 4.80</div>
</td>
<td>
<div align="left">
<p>Cameron Wake is approaching his late 30s, and Robert Quinn has struggled to stay healthy recently, so developing another edge pass rusher should be high on Miami's list. The team has been rumored to be looking at a quarterback, as well, but that could be difficult if the Dolphins don't move up. Edmunds is a capable pass rusher who has also shown ability as an inside backer.</p>
<p>42. Miami Dolphins: Maurice Hurst, DT, Michigan. Replacing Ndamukong Suh won't be easy, but there are plenty of players capable of helping the Dolphins on the interior in this year's draft. Hurst had a total of 10.5 sacks over the last two seasons for the Wolverines.</p>
</div>
</td>
<td>
<div align="center">Apr 4</div>
</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><span data-offset-key="bmde1-0-0"><span data-text="true">Go Fins!</span></span></p>
<p>Big Dave</p>
<p><img style="margin: 10px;" src="http://www4.ncsu.edu/%7Edwblake/christianfish.gif" alt="" /></p>
<p>&nbsp;</p>
<p><img src="http://www.phinfever.com/MBimages/phinfever_watermark.png" alt="" /></p>
<p>&nbsp;</p> </div><div class="dd-pager"><a href="/index.php/9-blog/354-2018-phinfever-mock-draft-for-the-miami-dolphins" rel="next">Next &gt;</a></div></div><div class="dd-postmetadatafooter"><div class="dd-postfootericons dd-metadata-icons"><span class="dd-posttagicon">	<div class="tags">
																	<span class="tag-2 tag-list0">
					<a href="/index.php/component/tags/tag/2-nfl-draft" class="label label-info">
						NFL Draft					</a>
				</span>&nbsp;
																				<span class="tag-3 tag-list1">
					<a href="/index.php/component/tags/tag/3-phinfever" class="label label-info">
						 Phinfever					</a>
				</span>&nbsp;
																				<span class="tag-4 tag-list2">
					<a href="/index.php/component/tags/tag/4-miami-dolphins" class="label label-info">
						Miami Dolphins					</a>
				</span>&nbsp;
																				<span class="tag-5 tag-list3">
					<a href="/index.php/component/tags/tag/5-mock-draft" class="label label-info">
						Mock Draft					</a>
				</span>&nbsp;
																				<span class="tag-9 tag-list4">
					<a href="/index.php/component/tags/tag/9-big-dave" class="label label-info">
						 Big Dave					</a>
				</span>&nbsp;
																				<span class="tag-132 tag-list5">
					<a href="/index.php/component/tags/tag/132-nfl" class="label label-info">
						NFL					</a>
				</span>&nbsp;
																				<span class="tag-166 tag-list6">
					<a href="/index.php/component/tags/tag/166-baker-mayfield" class="label label-info">
						Baker Mayfield					</a>
				</span>&nbsp;
																				<span class="tag-167 tag-list7">
					<a href="/index.php/component/tags/tag/167-vita-vea" class="label label-info">
						Vita Vea					</a>
				</span>&nbsp;
																				<span class="tag-168 tag-list8">
					<a href="/index.php/component/tags/tag/168-roquan-smith" class="label label-info">
						Roquan Smith					</a>
				</span>&nbsp;
																				<span class="tag-169 tag-list9">
					<a href="/index.php/component/tags/tag/169-tremaine-edmunds" class="label label-info">
						Tremaine Edmunds					</a>
				</span>&nbsp;
																				<span class="tag-170 tag-list10">
					<a href="/index.php/component/tags/tag/170-minkah-fitzpatrick" class="label label-info">
						Minkah Fitzpatrick					</a>
				</span>&nbsp;
																				<span class="tag-171 tag-list11">
					<a href="/index.php/component/tags/tag/171-derwin-james" class="label label-info">
						Derwin James					</a>
				</span>&nbsp;
						</div>
</span> | <span class="dd-postcategoryicon">Category: <span class="dd-post-metadata-category-name"><a href="/index.php/9-blog">Blog</a></span></span></div></div></article></div>


                        </div>
                        <div class="dd-layout-cell dd-sidebar2">
<div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Next Game</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p align="center"><a title="Next Game" href="/index.php/draft-central" target="_blank"><img title="Next Game" src="/2018/2018_002-nflDraft.jpg" alt="Next Game." width="180" height="200" /></a></p>
<p align="center">&nbsp;</p>
<p align="center"><a href="http://www.nfl.com/standings" target="_blank"><img src="/2017/schedule_020.gif" alt="AFC East Standings" width="180" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Support Phinfever</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="http://www.shareasale.com/r.cfm?B=466890&amp;U=1105867&amp;M=36369&amp;urllink=" target="_blank"><img style="display: block; margin-left: auto; margin-right: auto;" src="http://static.shareasale.com/image/36369/2014_AFL_160x600_G_DOLPHINS.jpg" alt="Get Miami Dolphins Game Day here!" /></a></p>
<p>&nbsp;</p>
<p align="center"><a title="Donate to Phinfever" href="https://www.paypal.com/us/verified/pal=bigdave1261%40bellsouth%2enet" target="_blank"><img src="/images/verification_seal.gif" alt="verification seal" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Phinfever - Jeopardy</h3></div><div class="dd-blockcontent"><div class="sp_simple_youtube">
					<iframe title="Simple youtube module by JoomShaper.com" id="sp-simple-youtube112" src="http://www.youtube.com/embed/XD5d-0S_RZo?wmode=transparent" frameborder="0"></iframe>
			</div>
			<script type="text/javascript">
			window.addEvent("domready", function() {
				spsyt('sp-simple-youtube112', 200, 200);
			});
			window.addEvent("resize", function() {
				spsyt('sp-simple-youtube112', 200, 200);
			});
		</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">DeVante Parker</h3></div><div class="dd-blockcontent"><div class="sp_simple_youtube">
					<iframe title="Simple youtube module by JoomShaper.com" id="sp-simple-youtube131" src="http://www.youtube.com/embed/S6mZ-NmLYxQ?wmode=transparent" frameborder="0"></iframe>
			</div>
			<script type="text/javascript">
			window.addEvent("domready", function() {
				spsyt('sp-simple-youtube131', 200, 145);
			});
			window.addEvent("resize", function() {
				spsyt('sp-simple-youtube131', 200, 145);
			});
		</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Fins Radio</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p>
<object id="13191" data="http://www.blogtalkradio.com/btrplayer.swf?file=http://www.blogtalkradio.com%2Ffinsradio%2Fplay_list.xml%3Fitemcount%3D5&amp;autostart=false&amp;bufferlength=5&amp;volume=80&amp;corner=rounded&amp;callback=http://www.blogtalkradio.com/flashplayercallback.aspx" type="application/x-shockwave-flash" width="190" height="270" name="13191"><param name="movie" value="http://www.blogtalkradio.com/btrplayer.swf?file=http://www.blogtalkradio.com%2Ffinsradio%2Fplay_list.xml%3Fitemcount%3D5&amp;autostart=false&amp;bufferlength=5&amp;volume=80&amp;corner=rounded&amp;callback=http://www.blogtalkradio.com/flashplayercallback.aspx" /><param name="quality" value="high" /><param name="wmode" value="transparent" /><param name="menu" value="false" /><param name="allowScriptAccess" value="always" /></object>
</p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2017 Draft</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/component/content/article?id=306:2017-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2017_2018a.gif" alt="" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2016 Draft</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/11-draft-central/217-2016-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2016_2017.gif" alt="2016 Miami Dolphins Draft, Phinfever" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2015 Draft</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="http://www.phinfever.com/index.php/9-blog/123-2015-nfl-draft-coverage-phinfever" target="_blank"><img style="display: block; margin-left: auto; margin-right: auto;" src="/draft/preview-draft2015_2018a.gif" alt="" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">ESPN's James Walker</h3></div><div class="dd-blockcontent"><a class="twitter-timeline" data-theme="light" data-link-color="##f68121" data-border-color="##015778"  data-chrome="nofooter noborders "  3  href="https://twitter.com/JamesWalkerNFL" data-widget-id="556182927797915649" width="200" height="350">Tweets by @JamesWalkerNFL</a>

<script type="text/javascript">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></div>

                        </div>
                    </div>
                </div>
            </div>

<footer class="dd-footer">
<span style="font-size: 12px; color: rgb(255, 255, 255);"><span style="color: rgb(255, 255, 255);">Copyright</span>&nbsp;© 2014</span> <span style="font-size: 12px; color: #F9DA6C;">... Phinfever.com ... since 1999</span>
</footer>

    </div>
    <p class="dd-page-footer">
        <span id="dd-footnote-links">Designed by <a href="http://www.diablodesign.eu" target="_blank">www.diablodesign.eu</a>.</span>
    </p>
</div>


</body>
</html>