<!DOCTYPE html>
<html dir="ltr" lang="en-gb">
<head>
      <base href="http://phinfever.com/index.php/9-blog/436-dolphins-draft-lt-austin-jackson-with-their-2nd-first-round-pick-draft-analyis-video-clips" />
  <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="keywords" content="Phinfever, Phinfever.com, Miami Dolphins, Fan Site, Miami Dolphins iPhone wallpapers, Miami Dolphins iPad wallpapers, Miami Dolphins fight song, ring tones, animated gifs, Dan Marino, Ryan Tannehill, Brent Grimes." />
  <meta name="author" content="admin" />
  <meta name="description" content="Phinfever - A Miami Dolphins daily fan site. Catch the Madness!" />
  <meta name="generator" content="Joomla! - Open Source Content Management" />
  <title>Dolphins draft LT Austin Jackson with their 2nd first round pick (draft analysis/video clips)</title>
  <link href="http://phinfever.com/index.php/9-blog/436-dolphins-draft-lt-austin-jackson-with-their-2nd-first-round-pick-draft-analyis-video-clips" rel="canonical" />
  <link href="/templates/dd_goldenline_32/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
  <link rel="stylesheet" href="/media/system/css/modal.css" type="text/css" />
  <link rel="stylesheet" href="/components/com_imageshow/assets/css/style.css" type="text/css" />
  <link rel="stylesheet" href="/plugins/jsnimageshow/themeslider/assets/css/style.css" type="text/css" />
  <link rel="stylesheet" href="/plugins/jsnimageshow/themeslider/assets/css/skitter/skitter.styles.css" type="text/css" />
  <style type="text/css">
.jsn-themeslider-skitter-0JQLs .label_skitter {filter:alpha(opacity=75);opacity: 0.75;}.jsn-themeslider-skitter-0JQLs .label_skitter p.jsn-themeslider-caption-title {font-family: Verdana;
font-size: 12px;
font-weight: bold;
text-align: left;
color: #E9E9E9;}.jsn-themeslider-skitter-0JQLs .label_skitter p.jsn-themeslider-caption-description {font-family: Arial;
font-size: 11px;
font-weight: normal;
text-align: left;
color: #AFAFAF;}.jsn-themeslider-skitter-0JQLs .label_skitter a.jsn-themeslider-caption-link {font-family: Verdana;
font-size: 11px;
font-weight: bold;
text-align: right;
color: #E06614;}.jsn-themeslider-skitter-0JQLs .info_slide {top: 15px;}.jsn-themeslider-skitter-0JQLs .info_slide_dots {top: 15px;}
  </style>
  <script src="/media/jui/js/jquery.min.js" type="text/javascript"></script>
  <script src="/media/jui/js/jquery-noconflict.js" type="text/javascript"></script>
  <script src="/media/jui/js/jquery-migrate.min.js" type="text/javascript"></script>
  <script src="/media/system/js/tabs-state.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-core.js" type="text/javascript"></script>
  <script src="/media/system/js/core.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-more.js" type="text/javascript"></script>
  <script src="/media/system/js/modal.js" type="text/javascript"></script>
  <script src="/media/system/js/caption.js" type="text/javascript"></script>
  <script src="/components/com_imageshow/assets/js/jquery.min.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/jsn_is_conflict.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.easing.1.3.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.animate-colors-min.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.skitter.js" type="text/javascript"></script>
  <script type="text/javascript">

		window.addEvent('domready', function() {

			SqueezeBox.initialize({});
			SqueezeBox.assign($$('a.modal'), {
				parse: 'rel'
			});
		});window.addEvent('domready', function() {
			$$('.hasTip').each(function(el) {
				var title = el.get('title');
				if (title) {
					var parts = title.split('::', 2);
					el.store('tip:title', parts[0]);
					el.store('tip:text', parts[1]);
				}
			});
			var JTooltips = new Tips($$('.hasTip'), {"maxTitleChars": 50,"fixed": false});
		});jQuery(window).on('load',  function() {
				new JCaption('img.caption');
			});function  spsyt(a, b, c){
			var id = document.id(a);
			var w = id.getParent().getWidth();
			var h = (c*w)/b;
			id.setStyles({
				'width': w,
				'height': h
			});
		}
  </script>
  <!-- start - swMenuFree 8.3_J2.5-J3.0 javascript and CSS links -->
  <script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/jquery-1.6.min.js"></script>
  <style type='text/css'>
<!--
#sfmenu {
 border-width: 3px ;
 border-color: #17050E ;
 padding-top: 16px ;
 padding-right: 10px ;
 padding-bottom: 14px ;
 padding-left: 10px ;
background-image:none ;
}
.sw-sf, .sw-sf * {
margin: 0  ; 
padding: 0  ; 
list-style: none  ; 
}
.sw-sf {
line-height: 1.0  ; 
}
.sw-sf hr {display: block; clear: left; margin: -0.66em 0; visibility: hidden;}
.sw-sf ul{
position: absolute; 
top: -999em; 
width: 10em; 
display: block; 
}
.sw-sf ul li {
width: 100%  ; 
}
.sw-sf li:hover {
z-index:300 ; 
}
.sw-sf li:hover {
visibility: inherit ; 
}
.sw-sf li {
float: left; 
position: relative; 
}
.sw-sf li li{
 top: 0  ; 
 left: 0; 
position: relative; 
}
.sw-sf a {
display: block; 
position: relative; 
}
.sw-sf li:hover ul ,
.sw-sf li.sfHover ul {
left: 0; 
top: 2.5em; 
z-index: 400; 
width:100%; 
}
ul.sw-sf li:hover li ul ,
ul.sw-sf li.sfHover li ul {
top: -999em; 
}
ul.sw-sf li li:hover ul ,
ul.sw-sf li li.sfHover ul {
left: 10em; 
top: 0; 
}
ul.sw-sf li li:hover li ul ,
ul.sw-sf li li.sfHover li ul {
top: -999em; 
}
ul.sw-sf li li li:hover ul ,
ul.sw-sf li li li.sfHover ul {
left: 10em; 
top: 0; 
}
#sfmenu {
position: relative; 
 border-width: 3px ;
 border-color: #17050E ;
top: 0px  ; 
left: 0px; 
}
.sf-section {
 border-color: #061C1B ;
}
.sw-sf li.sfHover li , .sw-sf li:hover li {
top:0px  ; 
left:0px  ; 
}
.sw-sf li.sfHover li.sfHover li {
top:0px ; 
left:0px ; 
}
.sw-sf a.item1 {
 padding-right: 30px ;
 padding-left: 27px ;
 font-size: 15px  ; 
 font-family: Times New Roman, Times, serif  ; 
 text-align: left  ; 
 font-weight: normal  ; 
 color: #7A7A7A  ; 
 margin-top: 20px ;
 font-style: normal ;
 text-decoration: none ;
 text-transform: none ;
 border-top-color: #F34AFF ;
 border-left-color: #F34AFF ;
 border-bottom-color: #F34AFF ;
 border-right: 0; 
 display: block; 
 white-space: nowrap; 
 position: relative; 
background-image:none ;
}
.sw-sf a.item1.last {
 border-right-color: #F34AFF ;
}
.sw-sf li.sfHover a.item1,
.sw-sf a:focus,
.sw-sf a:hover ,
.sw-sf a:active {
background-image:none ;
 color: #7A7A7A  ; 
}
.sw-sf .current a.item1{
background-image:none ;
 color: #7A7A7A  ; 
}
.sw-sf  a.item2 {
 padding-top: 9px ;
 padding-right: 29px ;
 padding-bottom: 10px ;
 padding-left: 15px ;
 font-size: 15px  ; 
 font-family: Times New Roman, Times, serif  ; 
 text-align: left  ; 
 font-weight: normal  ; 
 font-style: normal ;
 text-decoration: none ;
 text-transform: none ;
 display: block; 
 white-space: nowrap ; 
background-image:none ;
 position: relative; 
 border-top-color: #94FFB4 ;
 border-left-color: #94FFB4 ;
 border-right-color: #94FFB4 ;
 opacity:0.8; 
 filter:alpha(opacity=80) 
}
.sw-sf a.item2.last {
 border-bottom-color: #94FFB4 ;
}
.sw-sf li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf  a.item2:hover {
background-image:none ;
}
.sw-sf li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2{
background-image:none ;
}

-->
</style>
  <script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/hoverIntent.js"></script>
<script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/superfish.js"></script>
<script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/supersubs.js"></script>
  <!-- end - swMenuFree javascript and CSS links -->


    <link rel="stylesheet" href="/templates/system/css/system.css" />
    <link rel="stylesheet" href="/templates/system/css/general.css" />
<!--scroling head-->
<script src="/templates/dd_goldenline_32/js/scroling.js"></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function() {
		if($(this).scrollTop() != 0) {
			$('#toTop').fadeIn();	
		} else {
			$('#toTop').fadeOut();
		}
	});
 
	$('#toTop').click(function() {
		$('body,html').animate({scrollTop:0},800);
	});	
});
</script>
<!--end scroling-->
  <!--animacja-->
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>
<script type="text/javascript" src="/templates/dd_goldenline_32/js/s3Slider.js"></script>
<script type="text/javascript">
    $(document).ready(function() {
        $('#slider1').s3Slider({
            timeOut: 5000 
        });
    });
</script>
   </script> <!--end animacja-->
    
    
<meta name="viewport" content="initial-scale = 1.0, maximum-scale = 1.0, user-scalable = no, width = device-width" />

    <!--[if lt IE 9]><script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.css" media="screen" />
    <!--[if lte IE 7]><link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.ie7.css" media="screen" /><![endif]-->
    <link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.responsive.css" media="all" />

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link href="/css/template.css" rel="stylesheet" type="text/css">
<script>if ('undefined' != typeof jQuery) document._artxJQueryBackup = jQuery;</script>
    <script src="/templates/dd_goldenline_32/jquery.js"></script>
    <script>jQuery.noConflict();</script>

    <script src="/templates/dd_goldenline_32/script.js"></script>
    <script src="/templates/dd_goldenline_32/script.responsive.js"></script>
    <script src="/templates/dd_goldenline_32/modules.js"></script>
        <script>if (document._artxJQueryBackup) jQuery = document._artxJQueryBackup;</script>
</head>
<body>
<div id="toTop"><p>^Back To Top</p></div>
<div id="dd-main">
<header class="dd-header">
    <div class="dd-shapes"> 
  
        <div class="dd-object1981120983"></div>


<!--koniec animacja grafika-->
<div class="dd-object56742192"></div>
<div class="dd-object1293778198"></div>

    
<div class="dd-textblock dd-object1936180298">
        <div class="dd-object1936180298-text-container">
        <div class="dd-object1936180298-text"></div>
    </div>
    
</div><div class="dd-textblock dd-object650926169">
        <div class="dd-object650926169-text-container">
        <div class="dd-object650926169-text"><p></p><br /></div>
    </div>
    
</div>
            </div>

<h1 class="dd-headline">
    <a href="/"></a>
</h1>
<h2 class="dd-slogan"></h2>


<div class="dd-textblock dd-textblock-1393176558">

    
</div>

<div class="dd-textblock dd-object714367995">
    <form class="dd-search" name="Search" action="/index.php" method="post">
    <input type="text" value="" name="searchword" />
    <input type="hidden" name="task" value="search" />
<input type="hidden" name="option" value="com_search" />
<input type="submit" value="Search" name="search" class="dd-search-button" />
</form>

</div>

<nav class="dd-nav">
    

<!--swMenuFree8.3_J2.5-3.0 superfishmenu by http://www.swmenupro.com-->
<div id="sfmenu" align="left" >
<ul  id="swmenu" class="sw-sf"  > 
<li id='sf-101' class='current'> 
<a href='/' class='item1'>Home</a>
</li> 
<li id='sf-116' > 
<a href="http://www.phinfever.com/forums/" target="_blank" class="item1" >Forums</a></li> 
<li id='sf-117' > 
<a href='/index.php/draft-central' class='item1'>Draft Central</a>
</li> 
<li id='sf-118' > 
<a href='/index.php/downloads' class='item1'>Downloads</a>
</li> 
<li id='sf-119' > 
<a href='/index.php/links' class='item1'>Links</a>
</li> 
<li id='sf-120' > 
<a href='/index.php/staff' class='item1 last'>Staff</a>
</li> 
</ul><hr style="display:block;clear:left;margin:-0.66em 0;visibility:hidden;" /></div> 
<script type="text/javascript">
<!--
jQuery(document).ready(function($){
$('.sw-sf').supersubs({ 
minWidth:8,
maxWidth:80,
extraWidth:2
}).superfish({
speed:   1,autoArrows:  false
});
$('.sw-sf').parents().css('z-index','1');
$('.sw-sf').css('z-index','501');
});
//-->
</script>

<!--End swMenuFree menu module-->
     </nav>

                    
</header>
<div class="dd-sheet clearfix">
            <div class="dd-layout-wrapper">
                <div class="dd-content-layout">
                    <div class="dd-content-layout-row">
                        <div class="dd-layout-cell dd-sidebar1">
<div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Phinfever: 20 + Years!</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><img src="/images/20years-logo.gif" alt="" width="180" /></p>
<p>&nbsp;</p>
<center>
<p>
<audio controls="controls"><source src="/images/fins_ready2.wav" type="audio/mpeg" /></audio>
</p>
</center></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Social Media</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="http://twitter.com/phinfever" target="_blank"><img src="/images/ani-twitter.gif" alt="Phinfever Twitter" width="60" height="60" /></a><a href="http://www.facebook.com/pages/Phinfever-Miami-Dolphins-Fan-Site/175907802443072" target="_blank"><img src="/images/ani-facebook.gif" alt="Phinfever Facebook" width="60" height="60" /></a><a href="/?format=feed&amp;type=rss" target="_blank"><img src="/images/ani-rssfeed.gif" alt="RSS Feed" width="60" height="60" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Draft Info</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="http://www.phinfever.com/index.php/9-blog/433-jammer-s-miami-dolphins-mock-1-0-post-combine-phinfever"><img src="/draft/2020_JammerMock-02.gif" alt="Dan Jamroz Phinfever Post Free Agency Mock 2020" width="190" height="95" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Draft Central</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a title="Phinfever Draft Central with Dan Jamroz" href="/index.php/draft-central"><img style="display: block; margin-left: auto; margin-right: auto;" src="http://www.phinfever.com/draft/banner_draftCentral_2017.gif" alt="Phinfever Draft Central - Complete Info On Miami Dolphins' draft picks." /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Post Game Analysis</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><img src="/images/gbu/goodBadUgly_2019.gif" alt="Phinfever, Dan Jamroz, The Good Bad Ugly" />&nbsp; <br /><strong><a href="/index.php/9-blog/414-ravens-59-dolphins-10-the-good-the-bad-and-the-ugly">0-1. Ravens 59, Dolphins 10<br /></a><a href="/index.php/9-blog/415-patriots-43-dolphins-0-the-good-bad-and-the-ugly">0-2. Patriots 43, Dolphins 0<br /></a><a href="/index.php/9-blog/416-dolphins-6-cowboys-31-the-good-the-bad-and-the-ugly">0-3. Dolphins 6, Cowboys 31<br /></a><a href="/index.php/9-blog/417-chargers-30-dolphins-10-the-good-bad-and-ugly">0-4. Chargers 30, Dolphins 10<br /></a><a href="/index.php/9-blog/418-redskins-17-dolphins-16-the-good-the-bad-and-the-ugly">0-5. Redskins 17, Dolphins 16<br /></a><a href="/index.php/9-blog/419-dolphins-21-bills-31-the-good-the-bad-and-the-ugly">0-6. Dolphins 21, Bills 31<br /></a><a href="/index.php/9-blog/420-dolphins-14-steelers-27-the-good-the-bad-and-the-ugly">0-7. Dolphins 14, Steelers 27<br /></a><a href="/index.php/9-blog/421-jets-18-dolphins-26-the-good-the-bad-and-the-ugly">1-7. Jets 18, Dolphins 26<br /></a><a href="http://www.phinfever.com/index.php/9-blog/422-dolphins-16-colts-21-the-good-the-bad-and-the-ugly">2-7. Dolphins 16, Colts 12 <br /></a><a href="http://www.phinfever.com/index.php/9-blog/423-bills-37-dolphins-20-the-good-the-bad-the-ugly">2-8. Bills 37, Dolphins 20<br /></a><a href="http://www.phinfever.com/index.php/9-blog/424-dolphins-24-browns-41-the-good-the-bad-the-ugly">2-9. Dolphins 24, Browns 41<br /></a><a href="/index.php/9-blog/425-eagles-31-dolphins-37-the-good-the-bad-the-ugly">3-9. Eagles 31, Dolphins 37<br /></a><a href="http://www.phinfever.com/index.php/9-blog/426-dolphins-21-jets-22-the-good-the-bad-the-ugly">3-10. Dolphins 21, Jets 22<br /></a><a href="http://www.phinfever.com/index.php/9-blog/427-dolphins-20-giants-36-the-good-the-bad-the-ugly">3-11. Dolphins 20, Giants 36<br /></a><a href="http://www.phinfever.com/index.php/9-blog/428-bengals-35-dolphins-38-the-good-the-bad-the-ugly">4-11. Bengals 35, Dolphins 38<br /></a><a href="/index.php/9-blog/429-dolphins-27-patriots-24-the-good-the-bad-the-ugly">5-11. Dolphins 27, Patriots 24</a></strong></p>
<p>&nbsp;</p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Fins 27, Patriots 24 Highlights</h3></div><div class="dd-blockcontent"><div class="sp_simple_youtube">
					<iframe title="Simple youtube module by JoomShaper.com" id="sp-simple-youtube131" src="http://www.youtube.com/embed/QShZYwHnlW8?wmode=transparent" frameborder="0"></iframe>
			</div>
			<script type="text/javascript">
			window.addEvent("domready", function() {
				spsyt('sp-simple-youtube131', 200, 145);
			});
			window.addEvent("resize", function() {
				spsyt('sp-simple-youtube131', 200, 145);
			});
		</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Books</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="https://www.amazon.com/dp/B07T2F5F1C/" target="_blank"><img style="display: block; margin-left: auto; margin-right: auto;" src="http://www.phinfever.com/images/banners/book-DanMarino.gif" alt="&quot;In Defense of Dan Marino&quot;" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Podcasts, Interviews</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="https://itunes.apple.com/us/podcast/dolphinstalk-com-daily/id1289046573?mt=2" target="_blank"><img src="http://www.phinfever.com/images/banners/banner_DolphinTalk-2018.png" alt="DolphinsTalk.com" width="200" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Phinfever FFL</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="http://www71.myfantasyleague.com/2019/home/21714#0" target="_blank"><img src="/images/banner_TRockFFL01.jpg" alt="T-Rock's Phinfever FFL 2014" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Phinfever - Jeopardy</h3></div><div class="dd-blockcontent"><div class="sp_simple_youtube">
					<iframe title="Simple youtube module by JoomShaper.com" id="sp-simple-youtube112" src="http://www.youtube.com/embed/XD5d-0S_RZo?wmode=transparent" frameborder="0"></iframe>
			</div>
			<script type="text/javascript">
			window.addEvent("domready", function() {
				spsyt('sp-simple-youtube112', 200, 200);
			});
			window.addEvent("resize", function() {
				spsyt('sp-simple-youtube112', 200, 200);
			});
		</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Armando Salguero</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a class="twitter-timeline" href="https://twitter.com/ArmandoSalguero?ref_src=twsrc%5Etfw" data-width="200" data-height="400" >Tweets by ArmandoSalguero</a> &nbsp;</p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Barry Jackson</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a class="twitter-timeline" href="https://twitter.com/flasportsbuzz?ref_src=twsrc%5Etfw" data-width="200" data-height="400" >Tweets by flasportsbuzz</a> &nbsp;</p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Dave Hyde</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<a class="twitter-timeline" data-width="200" data-height="400" href="https://twitter.com/davehydesports?ref_src=twsrc%5Etfw">Tweets by davehydesports</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></div></div>



                        </div>

                        <div class="dd-layout-cell dd-content">
<!-- begin nostyle -->
<div class="dd-nostyle">
<!-- begin nostyle content -->
<!-- JSN IMAGESHOW FREE 4.8.1 - Theme Slider 1.1.7 --><div class="jsn-container"><div class="jsn-gallery"><div id="jsn-themeslider-skitter-0JQLs"><div style="width: 500px; height: 300px;" class="box_skitter jsn-themeslider-gallery jsn-themeslider-skitter-0JQLs">
<ul><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg" alt="001.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">001.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg" alt="002.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">002.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg" alt="003.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">003.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg" alt="004.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">004.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg" alt="005.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">005.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg" alt="006.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">006.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg" alt="007.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">007.jpg</p></div>
					 </li></ul><input type="hidden" class="cache_skitter_index" value="" /></div>
</div><script type="text/javascript">
						jsnThemeSliderjQuery(function() {
						jsnThemeSliderjQuery(document).ready(function(){
							var wrap_width = parseInt(500);
							var window_width = parseInt(jsnThemeSliderjQuery(window).width());
							if (wrap_width > window_width) {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-0JQLs').css("width", "100%");
							} else {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-0JQLs').css("width", "500px");
							}
							var oldHTML = jsnThemeSliderjQuery('#jsn-themeslider-skitter-0JQLs').html();
							var options = {"animation":"random","navigation":true,"navShowOnMouseOver":true,"dots":false,"numbers":false,"caption_title_css":"font-family: Verdana;\r\nfont-size: 12px;\r\nfont-weight: bold;\r\ntext-align: left;\r\ncolor: #E9E9E9;","caption_description_css":"font-family: Arial;\r\nfont-size: 11px;\r\nfont-weight: normal;\r\ntext-align: left;\r\ncolor: #AFAFAF;","caption_link_css":"font-family: Verdana;\r\nfont-size: 11px;\r\nfont-weight: bold;\r\ntext-align: right;\r\ncolor: #E06614;","caption_position":"bottom","caption_caption_opacity":"filter:alpha(opacity=75);opacity: 0.75;","interval":6000,"controls":false,"stop_over":true,"auto_play":true,"caption_title_show":true,"caption_description_show":true,"caption_link_show":false,"label":false,"animateNumberActive":{"backgroundColor":"#CC3333","color":"#fff"},"click_action":"no_action","open_link_in":"current_browser","skitter_class_id":"jsn-themeslider-skitter-0JQLs"};
							options.base_height = 300;
							jsnThemeSliderjQuery('.jsn-themeslider-skitter-0JQLs').skitter(options);
							jsnThemeSliderjQuery('.jsn-themeslider-skitter-0JQLs .image_main').css("max-width", "");
							var jsn_0JQLs = jsnThemeSliderjQuery(window).width();
							var cacheResize;
							jsnThemeSliderjQuery(window).resize(function (e) {
								if (jsn_0JQLs != jsnThemeSliderjQuery(window).width())
								{
									clearTimeout(cacheResize);
									cacheResize = "";
									var oldCacheIndex = jsnThemeSliderjQuery('#jsn-themeslider-skitter-0JQLs .cache_skitter_index').attr('value');
									jsnThemeSliderjQuery('#jsn-themeslider-skitter-0JQLs').html(oldHTML);
									var wrap_width = parseInt(500);
							var window_width = parseInt(jsnThemeSliderjQuery(window).width());
							if (wrap_width > window_width) {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-0JQLs').css("width", "100%");
							} else {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-0JQLs').css("width", "500px");
							}
									jsnThemeSliderjQuery('#jsn-themeslider-skitter-0JQLs .cache_skitter_index').attr('value', oldCacheIndex);
									var options = {"animation":"random","navigation":true,"navShowOnMouseOver":true,"dots":false,"numbers":false,"caption_title_css":"font-family: Verdana;\r\nfont-size: 12px;\r\nfont-weight: bold;\r\ntext-align: left;\r\ncolor: #E9E9E9;","caption_description_css":"font-family: Arial;\r\nfont-size: 11px;\r\nfont-weight: normal;\r\ntext-align: left;\r\ncolor: #AFAFAF;","caption_link_css":"font-family: Verdana;\r\nfont-size: 11px;\r\nfont-weight: bold;\r\ntext-align: right;\r\ncolor: #E06614;","caption_position":"bottom","caption_caption_opacity":"filter:alpha(opacity=75);opacity: 0.75;","interval":6000,"controls":false,"stop_over":true,"auto_play":true,"caption_title_show":true,"caption_description_show":true,"caption_link_show":false,"label":false,"animateNumberActive":{"backgroundColor":"#CC3333","color":"#fff"},"click_action":"no_action","open_link_in":"current_browser","skitter_class_id":"jsn-themeslider-skitter-0JQLs"};
									options.base_height = 300;
									cacheResize = setTimeout(function () {
										jsnThemeSliderjQuery('.jsn-themeslider-skitter-0JQLs').skitter(options);
										jsnThemeSliderjQuery('.jsn-themeslider-skitter-0JQLs .image_main').css("max-width", "");
									}, 500);
									jsn_0JQLs = jsnThemeSliderjQuery(window).width();
								}
							});
						})});
				</script><div class="jsn-themeslider-seocontent">
<p>Joomla gallery extension by <a href="http://www.joomlashine.com" title="Joomla gallery">joomlashine.com</a></p>
<div><p>2015 Dolphins Draft Picks</p><p></p><ul><li><p>001.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg</a></p></li><li><p>002.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg</a></p></li><li><p>003.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg</a></p></li><li><p>004.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg</a></p></li><li><p>005.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg</a></p></li><li><p>006.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg</a></p></li><li><p>007.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg</a></p></li></ul></div></div>
</div></div><!-- end nostyle content -->
</div>
<!-- end nostyle -->
<article class="dd-post dd-messages"><div class="dd-postcontent clearfix">
<div id="system-message-container">
</div></div></article><div class="item-page"><article class="dd-post"><div class="dd-postmetadataheader"><h2 class="dd-postheader"><a href="/index.php/9-blog/436-dolphins-draft-lt-austin-jackson-with-their-2nd-first-round-pick-draft-analyis-video-clips">Dolphins draft LT Austin Jackson with their 2nd first round pick (draft analysis/video clips)</a></h2></div><div class="dd-postheadericons dd-metadata-icons"><span class="dd-postdateicon">Published: Friday, 24 April 2020 03:10</span> | <span class="dd-postauthoricon">Written by admin</span> | <a href="/index.php/9-blog/436-dolphins-draft-lt-austin-jackson-with-their-2nd-first-round-pick-draft-analyis-video-clips?tmpl=component&amp;print=1&amp;page=" title="Print" onclick="window.open(this.href,'win2','status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=yes,width=640,height=480,directories=no,location=no'); return false;" rel="nofollow"><img src="/templates/dd_goldenline_32/images/system/printButton.png" alt="Print" /></a> | <a href="/index.php/component/mailto/?tmpl=component&amp;template=dd_goldenline_32&amp;link=a314d796f35878e9c4be7faed70012eac66ff951" title="Email" onclick="window.open(this.href,'win2','width=400,height=350,menubar=yes,resizable=yes'); return false;"><img src="/templates/dd_goldenline_32/images/system/emailButton.png" alt="Email" /></a> | Hits: 43</div><div class="dd-postcontent clearfix"><div class="dd-article"><p><strong>CONTENT</strong><a href="#postdraft"><br /></a></p>
<p><a href="#postdraft">Post Draft Analysis</a><br /><a href="#youtube">Youtube Highlights</a><br /><a href="#espn">ESPN Insider Draft Analysis</a> (paid subscription)<br /><a href="#nflcom">NFL.COM Draft Analysis</a><br /> <a href="#draftbible">NFL Draft Bible Analysis</a> (paid subscription) <br /> <a href="#pff">Pro Football Focus Draft Analysis</a> (paid subscription)<br /> <a href="#pfn">Pro Football Network (Tony Pauline) Analysis</a><br /> <a href="#walter">Walter Football Analysis</a><br /> <a href="#br">Bleacher Report Analysis<br /><br /></a></p>
<p><img src="http://www.phinfever.com/draft/2020-01b_AustinJackson-001.gif" alt="" width="400" height="414" /></p>
<p>&nbsp;</p>
<p><strong><a id="postdraft" name="postdraft"></a></strong><strong>POST DRAFT ANALYSIS</strong></p>
<p>(Coming soon)</p>
<p>&nbsp;</p>
<p><a id="youtube" name="youtube"></a></p>
<p><iframe src="https://www.youtube.com/embed/aO2EjdkCvus" width="465" height="262" allowfullscreen="allowfullscreen" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"></iframe></p>
<p>&nbsp;</p>
<p><iframe src="https://www.youtube.com/embed/AhJ7-Mnw6BY" width="465" height="262" allowfullscreen="allowfullscreen" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"></iframe></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a id="espn" name="espn"></a></p>
<p><a href="http://insider.espn.com/nfl/draft/player/_/id/103516" target="_blank"><img src="http://www.phinfever.com/draft/ESPN-DraftLogo.gif" alt="" /></a></p>
<p>Jackson, a true junior in 2019, was a two-year starter at left tackle. He gets off the ball and flashes the ability to move defenders in the run game. He flashes a violent punch. He has the potential to develop into an above-average pass-blocker. He's quick and long enough to handle speed off the edge. He does an above-average job of resetting his hands and recovering. He gives ground when he doesn't win with his hands initially. He oversets and gets beaten to the inside at times. The 2019 Notre Dame tape shows the good and the bad in pass pro. -- March 2020</p>
<p><strong>Pre-Draft Analysis</strong><br /> Jackson gets off the ball and flashes the ability to move defenders in the run game. He has a violent punch and has the potential to develop into a good pass-blocker. He's quick and long enough to handle speed off the edge. He does an above-average job of resetting his hands and recovering. Jackson is inconsistent, however, and the 2019 Notre Dame tape shows the good and the bad in pass protection. -- Steve Muench</p>
<p>&nbsp;</p>
<p><a id="nflcom" name="nflcom"></a></p>
<p><a href="https://www.nfl.com/draft/tracker/prospects" target="_blank"><img src="http://www.phinfever.com/draft/banner-nflcom.gif" alt="" border="0" /></a></p>
<p><strong>Player Bio</strong><br /> Many USA Today High School All-Americans face the most important choice of their young lives when picking a school. Jackson's selection of USC was not nearly as important, however, as his decision to donate bone marrow to his younger sister in the summer of 2019. The procedure went well, and Jackson returned to the Trojans for his junior season. He started all 13 games at left tackle in 2019, garnering first-team All-Pac-12 notice for his efforts. As a freshman, Jackson played in all 14 games as a reserve and on special teams. The next season, the Phoenix, Arizona, native started all 12 games at left tackle. Jackson's grandfather, Melvin, played on the offensive line for the Trojans' 1974 national championship team and for the Green Bay Packers for five years.</p>
<p><strong>Analysis</strong></p>
<ul>
<li>NFL Comparison: D.J. Humphries</li>
</ul>
<p><strong>Overview</strong><br /> Early-entry tackle prospect who is raw but gifted and is likely to be coveted by a variety of teams, thanks to his true left tackle traits. Jackson has loads of athletic ability and play talent that is waiting to be developed and harvested. Inconsistent hand placement and footwork could be exploited early on if teams try and rush him into the starting lineup, but issues are correctable. He's scheme-diverse with potential guard flexibility if he improves his strength. He could become an early starter but may offer a wider split between floor and ceiling than some teams might like.</p>
<p><strong>Strengths</strong></p>
<ul>
<li>Outstanding athleticism on athletic frame</li>
<li>Room for additional mass and development</li>
<li>Nimble feet and quick twitch headline his athletic gifts</li>
<li>Flashes bend and initial pop as drive-blocker</li>
<li>Initial lateral steps gain ground quickly</li>
<li>Quick to second level on cutoff blocks</li>
<li>Rangy -- capable in long pulls and wide receiver screens</li>
<li>Rapid kick slide offers mirroring mechanism against speed</li>
<li>Slick splash technique to create imbalance from rushers</li>
<li>Ability to redirect against counters</li>
<li>Athleticism for above-average recovery talent</li>
<li>Can run the rusher up and around the pocket</li>
<li>Has blocked two kicks at USC and five in high school</li>
</ul>
<p><strong>Weaknesses</strong></p>
<ul>
<li>Technique issues show up on tape</li>
<li>Footwork can be jumpy and undisciplined</li>
<li>Needs to improve upper body and core strength</li>
<li>Infrequent use of inside hands diminishes power</li>
<li>Lacks hand placement to sustain and steer the defender</li>
<li>Low hands can be tardy to land first</li>
<li>Too much hunching forward into punch</li>
<li>Overextends causing fluctuation in base width</li>
<li>Average body composure to handle counters</li>
</ul>
<p>&nbsp;</p>
<p><a id="draftbible" name="draftbible"></a></p>
<p><img src="http://www.phinfever.com/draft/NFLdraftBible.gif" alt="" /></p>
<p><strong>AUSTIN JACKSON | USC | OT | #73 | JR | 6047 </strong>|<br /> 322 | 1028 | 3418 | 8200 | 5.07 | Phoenix, AX | North Canyon HS |<br /> 08.11.99 | NIC | 8.0/9.2 | Rd2</p>
<p><strong>Overview:</strong><br /> Possesses long, wide, athletic frame; prototypical size—has gained over 50 pounds since arriving to USC and still has room to grow. Shows strong hands, excellent placement and<br /> great bend. However, he can overextend himself at times and be caught out of place. A two-year starter who played special teams as a freshman. Has NFL bloodlines. Underwent an altruistic<br /> surgical procedure during the summer of 2019, to donate bone marrow to his sister Autumn, who suffers from Diamond-Blackfan anemia. Overall, his combination of size, athleticism and<br /> upside could make him a top 50 overall selection.</p>
<p><strong>Background:</strong><br /> Grew up in a single-parent household with his mother Lavonna Buckhanan. Played offensive tackle and defensive end at North Canyon High in Phoenix, Arizona. He also was on<br /> North Canyon’s track and basketball teams. Majored in political science at USC. His grandfather, Melvin Jackson, was a 1974 and 1975 letterman offensive tackle at USC. He then went on to<br /> play 5 years (1976-80) in the NFL with the Green Bay Packers after being their 12th round pick in the 1976 Draft. Jackson returned healthy to the Trojans for his junior season after donating bone marrow to his sister in the summer of 2019.</p>
<p><strong>Career:</strong><br /> Started all 13 games at left tackle in 2019 and 2018, garnering first-team All-Pac-12 honors. As a freshman, Jackson played in all 14 games and contributed on special teams.</p>
<p><strong>Q&amp;A:</strong><br /> <em>How did you wind up being a bone marrow donor for your sister?</em> My sister has a rare blood disorder which causes your body not to produce red blood cells. She's had it since she was<br /> born. The procedure I did, the bone marrow transplant, allows her body to accept my blood cells. Thank god we were a perfect match through blood testing. That allowed her to fully restart<br /> her system and her body is now producing red blood cells.</p>
<p><strong>Q&amp;A: </strong><br /> <em>What did you learn from your grandfather, Melvin, who played for the Packers?</em> It's a business. You have to show up every day, work to get better. There's some technique stuff he's<br /> showed me, but football in the '70s is a lot different than football now. But the biggest thing he's taught me is show up every day, work hard, and make the most for yourself.</p>
<p><strong>Q&amp;A:</strong><br /> <em>Have you stayed connected with any of the great Trojans tackles from years past?</em> Yes. I talk to guys like Anthony Munoz who come back. He's a legend, Hall of Famer. Guys like Tyron<br /> Smith, talked to him a couple times. Look forward to training with him this offseason. Sam Baker, another great, comes back a lot. There's a handful of them.</p>
<p>&nbsp;</p>
<p><a id="pff" name="pff"></a></p>
<p><img src="http://www.phinfever.com/draft/PFF.gif" alt="" width="475" height="70" /></p>
<p><strong>PROS &amp; CONS</strong></p>
<p><img src="http://www.phinfever.com/draft/2020-01b_AustinJackson-002.gif" alt="" width="465" height="246" /></p>
<p>&nbsp;</p>
<p><strong>COMPARABLES</strong></p>
<p><img src="http://www.phinfever.com/draft/2020-01b_AustinJackson-003.gif" alt="" width="465" height="181" /></p>
<p><img src="http://www.phinfever.com/draft/2020-01b_AustinJackson-004.gif" alt="" width="465" height="167" /></p>
<p>&nbsp;</p>
<p><a id="pfn" name="pfn"></a></p>
<p><a href="https://www.profootballnetwork.com/2020-nfl-draft-prospects-rankings-scouting-reports-tony-pauline/" target="_blank"><img src="/draft/PFN.gif" alt="" border="0" /></a></p>
<p><strong>Austin Jackson, OT, USC</strong></p>
<p><strong>Positives</strong><br /> Athletic tackle who is one of the best pass protectors in this year’s draft. Quickly sets up off the snap, keeps his head on a swivel and displays good vision. Picks up stunts and blitzes, adjusts to speed rushers and effectively knocks them from their angles of attack with a strong hand punch.</p>
<p>Bends his knees, sets with a wide base and keeps his feet moving. Stays square and seals defenders from the action. Easily slides off the edge, makes outstanding use of angles and displays terrific lateral range. Flexible, resilient and stays with plays. Has a nasty mentality and attacks blocks.</p>
<p><strong>Negatives</strong><br /> Must improve as a run blocker. Does not get much movement and gets held up at the point by defenders. Has a tendency to fall off blocks rather than finish them.</p>
<p><strong>Analysis</strong><br /> Jackson was a terrific left tackle for the Trojans the past two seasons and displayed good athleticism during combine testing. He comes with big upside and starting potential and should only improve as he physically matures.</p>
<p>&nbsp;</p>
<p><a id="pfn4" name="walter"></a></p>
<p><a href="https://walterfootball.com/scoutingreports.php" target="_blank"><img src="/draft/WalterFootball.gif" alt="" border="0" /></a></p>
<p><strong>Austin Jackson*, OT, USC</strong><br /> Height: 6-5. Weight: 322. Arm: 34.13. Hand: 10.25.<br /> 40 Time: 5.07.<br /> Projected Round (2020): 1-2.</p>
<p>4/21/20: In speaking to some team sources, they believe Jackson will be a first-round pick, but if offensive linemen get pushed down because of the amount of prospects, he might be an early second-round pick. Jackson had a solid combine with a fast 40 and a good workout.</p>
<p>Evaluators say Jackson is a great athlete with quick feet and excellent agility. He is an easy mover with the ability to bend at the knee and play with good leverage. There were times where Jackson got away with some mistakes because of his athleticism, and he will need to work on technique for the NFL. Jackson is raw from a fundamentals standpoint, and that was exposed by A.J. Epenesa in Iowa's bowl win, but Jackson's skill set is that of a franchise left tackle.</p>
<p>Earlier in 2019, Jackson took a leave from the Trojans in order to donate bone marrow to his younger sister, and he played extremely well after returning to the team.</p>
<p>&nbsp;</p>
<p><a id="pfn5" name="br"></a></p>
<p><a href="https://bleacherreport.com/articles/2888165-nfl-draft-2020-round-1-grades-for-every-pick" target="_blank"><img src="http://www.phinfever.com/draft/BleacherReport.gif" alt="" width="445" height="50" border="0" /></a><a href="https://walterfootball.com/scoutingreports.php" target="_blank"></a></p>
<p>Austin Jackson, Tackle, USC</p>
<p>Strengths: Size, effort-hustle</p>
<p>Weaknesses: Fluidity</p>
<p>Jackson is one of the feel-good stories of this year's draft: He took time off from football in the 2019 offseason to give his sister a bone-marrow transplant to correct a rare, dangerous blood disorder. Here's an ESPN video that tells the story better than we can in the space provided. Jackson told reporters at the combine that his sister was making a full recovery. "I was happy. I was excited. But most importantly I just thanked God. It was a miracle, and I was glad I could do that for my family," he said.</p>
<p>On the field, Jackson is a get-the-job-done type. He's big, strong and alert when reading blitzes or mirroring his defender's moves, but he's very mechanically stiff. Agile pass-rushers will be able to beat him to the inside at the NFL level, and he'll whiff at the last second on some open-field blocks.</p>
<p>Jackson's lack of agility could make him a liability at left tackle, but he's physical and determined enough to hold his own on the right side or serve as a quality multi-position backup. Jackson's technique is not pretty, but he's enough of a brawler to help the Dolphins.</p>
<p>The Dolphins allowed a league-high (tied with the Panthers) 58 sacks last season. They traded left tackle Laremy Tunsil just before the start of last season, of course, because a) they wanted to straddle the rebuilding/tanking line as tightly as possible; and b) Bill O’Brien was leaking foolishness and draft picks. But that left them with J’Marcus Webb, whom I thought retired in 2014, starting at left tackle for a while. They fielded one of the worst offensive lines I have ever seen at the start of the season, and it only got a little better as the season progressed. So Jackson fills a need. But the Dolphins have dipped into the second tier of tackle prospects. They should have tried to move up for a Tristan Wirfs or move down for more assets.</p>
<p>Grade: C+</p>
<p>&nbsp;</p>
<p>&nbsp;</p> </div><div class="dd-pager"><a href="/index.php/9-blog/437-dolphins-draft-lt-austin-jackson-with-their-2nd-first-round-pick-draft-analyis-video-clips" rel="next">Next &gt;</a></div></div><div class="dd-postmetadatafooter"><div class="dd-postfootericons dd-metadata-icons"><span class="dd-posttagicon">	<div class="tags">
																	<span class="tag-2 tag-list0">
					<a href="/index.php/component/tags/tag/2-nfl-draft" class="label label-info">
						NFL Draft					</a>
				</span>&nbsp;
																				<span class="tag-3 tag-list1">
					<a href="/index.php/component/tags/tag/3-phinfever" class="label label-info">
						 Phinfever					</a>
				</span>&nbsp;
																				<span class="tag-4 tag-list2">
					<a href="/index.php/component/tags/tag/4-miami-dolphins" class="label label-info">
						Miami Dolphins					</a>
				</span>&nbsp;
																				<span class="tag-227 tag-list3">
					<a href="/index.php/component/tags/tag/227-2020" class="label label-info">
						2020					</a>
				</span>&nbsp;
																				<span class="tag-228 tag-list4">
					<a href="/index.php/component/tags/tag/228-austin-jackson" class="label label-info">
						Austin Jackson					</a>
				</span>&nbsp;
						</div>
</span> | <span class="dd-postcategoryicon">Category: <span class="dd-post-metadata-category-name"><a href="/index.php/9-blog">Blog</a></span></span></div></div></article></div>


                        </div>
                        <div class="dd-layout-cell dd-sidebar2">
<div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Next Game</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p align="center"><a title="Next Game" href="/index.php/draft-central" target="_blank"><img title="Next Game" src="/2020/2020_NFLDraft001.jpg" alt="NFL Free Agency" width="180" height="200" /></a></p>
<p align="center">&nbsp;</p>
<p align="center"><a href="http://www.nfl.com/standings" target="_blank"><img src="/2019/2019_standings-17.gif" alt="AFC East Standings" width="180" /></a></p>
<p align="center">&nbsp;</p>
<p align="center"><a href="http://www.tankathon.com/nfl" target="_blank"><img src="/2020/2020_draftOrder.gif" alt="2020 NFL Draft Order" width="180" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Support Phinfever</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="http://www.shareasale.com/r.cfm?B=466890&amp;U=1105867&amp;M=36369&amp;urllink=" target="_blank"><img style="display: block; margin-left: auto; margin-right: auto;" src="http://static.shareasale.com/image/36369/2014_AFL_160x600_G_DOLPHINS.jpg" alt="Get Miami Dolphins Game Day here!" /></a></p>
<p>&nbsp;</p>
<p align="center"><a title="Donate to Phinfever" href="https://www.paypal.com/us/verified/pal=bigdave1261%40bellsouth%2enet" target="_blank"><img src="/images/verification_seal.gif" alt="verification seal" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2019 Draft</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/component/content/article?id=398:2019-nfl-draft-coverage-phinfever"><img style="float: left;" src="/draft/preview-draft2019-03.gif" alt="" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2018 Draft</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a title="Phinfever's 2018 Miami Dolphins Draft Coverage" href="/index.php/component/content/article?id=353:2018-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2018-02.gif" alt="" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2017 Draft</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/component/content/article?id=306:2017-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2017-02.gif" alt="" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2016 Draft</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/11-draft-central/217-2016-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2016-2019c.gif" alt="2016 Miami Dolphins Draft, Phinfever" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2015 Draft</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="http://www.phinfever.com/index.php/9-blog/123-2015-nfl-draft-coverage-phinfever" target="_blank"><img style="display: block; margin-left: auto; margin-right: auto;" src="/draft/preview-draft2015_03.gif" alt="" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">MiamiDolphins.com</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<a class="twitter-timeline" data-width="200" data-height="400" href="https://twitter.com/MiamiDolphins?ref_src=twsrc%5Etfw">Tweets by MiamiDolphins</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Cameron Wolfe</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a class="twitter-timeline" href="https://twitter.com/CameronWolfe?ref_src=twsrc%5Etfw" data-width="200" data-height="400">Tweets by CameronWolfe</a> &nbsp;</p></div></div></div>

                        </div>
                    </div>
                </div>
            </div>

<footer class="dd-footer">
<span style="font-size: 12px; color: rgb(255, 255, 255);"><span style="color: rgb(255, 255, 255);">Copyright</span>&nbsp;© 2014</span> <span style="font-size: 12px; color: #F9DA6C;">... Phinfever.com ... since 1999</span>
</footer>

    </div>
    <p class="dd-page-footer">
        <span id="dd-footnote-links">Designed by <a href="http://www.diablodesign.eu" target="_blank">www.diablodesign.eu</a>.</span>
    </p>
</div>


</body>
</html>