<!DOCTYPE html>
<html dir="ltr" lang="en-gb">
<head>
      <base href="http://phinfever.com/index.php/9-blog/465-chiefs-33-dolphins-27-the-good-the-bad-and-the-ugly" />
  <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="keywords" content="Phinfever, Phinfever.com, Miami Dolphins, Fan Site, Miami Dolphins iPhone wallpapers, Miami Dolphins iPad wallpapers, Miami Dolphins fight song, ring tones, animated gifs, Dan Marino, Ryan Tannehill, Brent Grimes." />
  <meta name="author" content="Rich Rodriguez" />
  <meta name="description" content="Phinfever - A Miami Dolphins daily fan site. Catch the Madness!" />
  <meta name="generator" content="Joomla! - Open Source Content Management" />
  <title>Chiefs 33, Dolphins 27 - The Good, The Bad and The Ugly</title>
  <link href="http://phinfever.com/index.php/9-blog/465-chiefs-33-dolphins-27-the-good-the-bad-and-the-ugly" rel="canonical" />
  <link href="/templates/dd_goldenline_32/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
  <link rel="stylesheet" href="/media/system/css/modal.css" type="text/css" />
  <link rel="stylesheet" href="/components/com_imageshow/assets/css/style.css" type="text/css" />
  <link rel="stylesheet" href="/plugins/jsnimageshow/themeslider/assets/css/style.css" type="text/css" />
  <link rel="stylesheet" href="/plugins/jsnimageshow/themeslider/assets/css/skitter/skitter.styles.css" type="text/css" />
  <style type="text/css">
.jsn-themeslider-skitter-GL06C .label_skitter {filter:alpha(opacity=75);opacity: 0.75;}.jsn-themeslider-skitter-GL06C .label_skitter p.jsn-themeslider-caption-title {font-family: Verdana;
font-size: 12px;
font-weight: bold;
text-align: left;
color: #E9E9E9;}.jsn-themeslider-skitter-GL06C .label_skitter p.jsn-themeslider-caption-description {font-family: Arial;
font-size: 11px;
font-weight: normal;
text-align: left;
color: #AFAFAF;}.jsn-themeslider-skitter-GL06C .label_skitter a.jsn-themeslider-caption-link {font-family: Verdana;
font-size: 11px;
font-weight: bold;
text-align: right;
color: #E06614;}.jsn-themeslider-skitter-GL06C .info_slide {top: 15px;}.jsn-themeslider-skitter-GL06C .info_slide_dots {top: 15px;}
  </style>
  <script src="/media/jui/js/jquery.min.js" type="text/javascript"></script>
  <script src="/media/jui/js/jquery-noconflict.js" type="text/javascript"></script>
  <script src="/media/jui/js/jquery-migrate.min.js" type="text/javascript"></script>
  <script src="/media/system/js/tabs-state.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-core.js" type="text/javascript"></script>
  <script src="/media/system/js/core.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-more.js" type="text/javascript"></script>
  <script src="/media/system/js/modal.js" type="text/javascript"></script>
  <script src="/media/system/js/caption.js" type="text/javascript"></script>
  <script src="/components/com_imageshow/assets/js/jquery.min.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/jsn_is_conflict.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.easing.1.3.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.animate-colors-min.js" type="text/javascript"></script>
  <script src="/plugins/jsnimageshow/themeslider/assets/js/skitter/jquery.skitter.js" type="text/javascript"></script>
  <script type="text/javascript">

		window.addEvent('domready', function() {

			SqueezeBox.initialize({});
			SqueezeBox.assign($$('a.modal'), {
				parse: 'rel'
			});
		});window.addEvent('domready', function() {
			$$('.hasTip').each(function(el) {
				var title = el.get('title');
				if (title) {
					var parts = title.split('::', 2);
					el.store('tip:title', parts[0]);
					el.store('tip:text', parts[1]);
				}
			});
			var JTooltips = new Tips($$('.hasTip'), {"maxTitleChars": 50,"fixed": false});
		});jQuery(window).on('load',  function() {
				new JCaption('img.caption');
			});function  spsyt(a, b, c){
			var id = document.id(a);
			var w = id.getParent().getWidth();
			var h = (c*w)/b;
			id.setStyles({
				'width': w,
				'height': h
			});
		}
  </script>
  <!-- start - swMenuFree 8.3_J2.5-J3.0 javascript and CSS links -->
  <script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/jquery-1.6.min.js"></script>
  <style type='text/css'>
<!--
#sfmenu {
 border-width: 3px ;
 border-color: #17050E ;
 padding-top: 16px ;
 padding-right: 10px ;
 padding-bottom: 14px ;
 padding-left: 10px ;
background-image:none ;
}
.sw-sf, .sw-sf * {
margin: 0  ; 
padding: 0  ; 
list-style: none  ; 
}
.sw-sf {
line-height: 1.0  ; 
}
.sw-sf hr {display: block; clear: left; margin: -0.66em 0; visibility: hidden;}
.sw-sf ul{
position: absolute; 
top: -999em; 
width: 10em; 
display: block; 
}
.sw-sf ul li {
width: 100%  ; 
}
.sw-sf li:hover {
z-index:300 ; 
}
.sw-sf li:hover {
visibility: inherit ; 
}
.sw-sf li {
float: left; 
position: relative; 
}
.sw-sf li li{
 top: 0  ; 
 left: 0; 
position: relative; 
}
.sw-sf a {
display: block; 
position: relative; 
}
.sw-sf li:hover ul ,
.sw-sf li.sfHover ul {
left: 0; 
top: 2.5em; 
z-index: 400; 
width:100%; 
}
ul.sw-sf li:hover li ul ,
ul.sw-sf li.sfHover li ul {
top: -999em; 
}
ul.sw-sf li li:hover ul ,
ul.sw-sf li li.sfHover ul {
left: 10em; 
top: 0; 
}
ul.sw-sf li li:hover li ul ,
ul.sw-sf li li.sfHover li ul {
top: -999em; 
}
ul.sw-sf li li li:hover ul ,
ul.sw-sf li li li.sfHover ul {
left: 10em; 
top: 0; 
}
#sfmenu {
position: relative; 
 border-width: 3px ;
 border-color: #17050E ;
top: 0px  ; 
left: 0px; 
}
.sf-section {
 border-color: #061C1B ;
}
.sw-sf li.sfHover li , .sw-sf li:hover li {
top:0px  ; 
left:0px  ; 
}
.sw-sf li.sfHover li.sfHover li {
top:0px ; 
left:0px ; 
}
.sw-sf a.item1 {
 padding-right: 30px ;
 padding-left: 27px ;
 font-size: 15px  ; 
 font-family: Times New Roman, Times, serif  ; 
 text-align: left  ; 
 font-weight: normal  ; 
 color: #7A7A7A  ; 
 margin-top: 20px ;
 font-style: normal ;
 text-decoration: none ;
 text-transform: none ;
 border-top-color: #F34AFF ;
 border-left-color: #F34AFF ;
 border-bottom-color: #F34AFF ;
 border-right: 0; 
 display: block; 
 white-space: nowrap; 
 position: relative; 
background-image:none ;
}
.sw-sf a.item1.last {
 border-right-color: #F34AFF ;
}
.sw-sf li.sfHover a.item1,
.sw-sf a:focus,
.sw-sf a:hover ,
.sw-sf a:active {
background-image:none ;
 color: #7A7A7A  ; 
}
.sw-sf .current a.item1{
background-image:none ;
 color: #7A7A7A  ; 
}
.sw-sf  a.item2 {
 padding-top: 9px ;
 padding-right: 29px ;
 padding-bottom: 10px ;
 padding-left: 15px ;
 font-size: 15px  ; 
 font-family: Times New Roman, Times, serif  ; 
 text-align: left  ; 
 font-weight: normal  ; 
 font-style: normal ;
 text-decoration: none ;
 text-transform: none ;
 display: block; 
 white-space: nowrap ; 
background-image:none ;
 position: relative; 
 border-top-color: #94FFB4 ;
 border-left-color: #94FFB4 ;
 border-right-color: #94FFB4 ;
 opacity:0.8; 
 filter:alpha(opacity=80) 
}
.sw-sf a.item2.last {
 border-bottom-color: #94FFB4 ;
}
.sw-sf li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2,
.sw-sf li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf li.sfHover  li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover a.item2:hover,
.sw-sf  a.item2:hover {
background-image:none ;
}
.sw-sf li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2,
.sw-sf li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li.sfHover li a.item2{
background-image:none ;
}

-->
</style>
  <script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/hoverIntent.js"></script>
<script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/superfish.js"></script>
<script type="text/javascript" src="http://phinfever.com/modules/mod_swmenufree/supersubs.js"></script>
  <!-- end - swMenuFree javascript and CSS links -->


    <link rel="stylesheet" href="/templates/system/css/system.css" />
    <link rel="stylesheet" href="/templates/system/css/general.css" />
<!--scroling head-->
<script src="/templates/dd_goldenline_32/js/scroling.js"></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function() {
		if($(this).scrollTop() != 0) {
			$('#toTop').fadeIn();	
		} else {
			$('#toTop').fadeOut();
		}
	});
 
	$('#toTop').click(function() {
		$('body,html').animate({scrollTop:0},800);
	});	
});
</script>
<!--end scroling-->
  <!--animacja-->
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>
<script type="text/javascript" src="/templates/dd_goldenline_32/js/s3Slider.js"></script>
<script type="text/javascript">
    $(document).ready(function() {
        $('#slider1').s3Slider({
            timeOut: 5000 
        });
    });
</script>
   </script> <!--end animacja-->
    
    
<meta name="viewport" content="initial-scale = 1.0, maximum-scale = 1.0, user-scalable = no, width = device-width" />

    <!--[if lt IE 9]><script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.css" media="screen" />
    <!--[if lte IE 7]><link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.ie7.css" media="screen" /><![endif]-->
    <link rel="stylesheet" href="/templates/dd_goldenline_32/css/template.responsive.css" media="all" />

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link href="/css/template.css" rel="stylesheet" type="text/css">
<script>if ('undefined' != typeof jQuery) document._artxJQueryBackup = jQuery;</script>
    <script src="/templates/dd_goldenline_32/jquery.js"></script>
    <script>jQuery.noConflict();</script>

    <script src="/templates/dd_goldenline_32/script.js"></script>
    <script src="/templates/dd_goldenline_32/script.responsive.js"></script>
    <script src="/templates/dd_goldenline_32/modules.js"></script>
        <script>if (document._artxJQueryBackup) jQuery = document._artxJQueryBackup;</script>
</head>
<body>
<div id="toTop"><p>^Back To Top</p></div>
<div id="dd-main">
<header class="dd-header">
    <div class="dd-shapes"> 
  
        <div class="dd-object1981120983"></div>


<!--koniec animacja grafika-->
<div class="dd-object56742192"></div>
<div class="dd-object1293778198"></div>

    
<div class="dd-textblock dd-object1936180298">
        <div class="dd-object1936180298-text-container">
        <div class="dd-object1936180298-text"></div>
    </div>
    
</div><div class="dd-textblock dd-object650926169">
        <div class="dd-object650926169-text-container">
        <div class="dd-object650926169-text"><p></p><br /></div>
    </div>
    
</div>
            </div>

<h1 class="dd-headline">
    <a href="/"></a>
</h1>
<h2 class="dd-slogan"></h2>


<div class="dd-textblock dd-textblock-1393176558">

    
</div>

<div class="dd-textblock dd-object714367995">
    <form class="dd-search" name="Search" action="/index.php" method="post">
    <input type="text" value="" name="searchword" />
    <input type="hidden" name="task" value="search" />
<input type="hidden" name="option" value="com_search" />
<input type="submit" value="Search" name="search" class="dd-search-button" />
</form>

</div>

<nav class="dd-nav">
    

<!--swMenuFree8.3_J2.5-3.0 superfishmenu by http://www.swmenupro.com-->
<div id="sfmenu" align="left" >
<ul  id="swmenu" class="sw-sf"  > 
<li id='sf-101' class='current'> 
<a href='/' class='item1'>Home</a>
</li> 
<li id='sf-116' > 
<a href="http://www.phinfever.com/forums/" target="_blank" class="item1" >Forums</a></li> 
<li id='sf-117' > 
<a href='/index.php/draft-central' class='item1'>Draft Central</a>
</li> 
<li id='sf-118' > 
<a href='/index.php/downloads' class='item1'>Downloads</a>
</li> 
<li id='sf-119' > 
<a href='/index.php/links' class='item1'>Links</a>
</li> 
<li id='sf-120' > 
<a href='/index.php/staff' class='item1 last'>Staff</a>
</li> 
</ul><hr style="display:block;clear:left;margin:-0.66em 0;visibility:hidden;" /></div> 
<script type="text/javascript">
<!--
jQuery(document).ready(function($){
$('.sw-sf').supersubs({ 
minWidth:8,
maxWidth:80,
extraWidth:2
}).superfish({
speed:   1,autoArrows:  false
});
$('.sw-sf').parents().css('z-index','1');
$('.sw-sf').css('z-index','501');
});
//-->
</script>

<!--End swMenuFree menu module-->
     </nav>

                    
</header>
<div class="dd-sheet clearfix">
            <div class="dd-layout-wrapper">
                <div class="dd-content-layout">
                    <div class="dd-content-layout-row">
                        <div class="dd-layout-cell dd-sidebar1">
<div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Phinfever: 20 + Years!</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><img src="/images/20years-logo.gif" alt="" width="180" /></p>
<p>&nbsp;</p>
<center>
<p>
<audio controls="controls"><source src="/images/fins_ready2.wav" type="audio/mpeg" /></audio>
</p>
</center></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Social Media</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="http://twitter.com/phinfever" target="_blank"><img src="/images/ani-twitter.gif" alt="Phinfever Twitter" width="60" height="60" /></a><a href="http://www.facebook.com/pages/Phinfever-Miami-Dolphins-Fan-Site/175907802443072" target="_blank"><img src="/images/ani-facebook.gif" alt="Phinfever Facebook" width="60" height="60" /></a><a href="/?format=feed&amp;type=rss" target="_blank"><img src="/images/ani-rssfeed.gif" alt="RSS Feed" width="60" height="60" /></a></p>
<p style="text-align: center;">&nbsp;</p>
<p style="text-align: center;"><a href="https://mewe.com/group/5fafd4284eea773af4634327" target="_blank"><img src="/images/ani_MeWee-60apx.gif" alt="Phinfever MeWee" height="60" /></a><a href="https://parler.com/profile/Phinfever/posts" target="_blank"><img src="/images/ani_Parler-60apx.gif" alt="Phinfever Parler" height="60" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Post Game Analysis</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><img src="/images/gbu/goodBadUgly_2017.gif" alt="Phinfever, Rich Rodriguez, The Good Bad Ugly" />&nbsp; <br /><strong><a href="http://www.phinfever.com/index.php/9-blog/448-dolphins-11-patriots-21-the-good-the-bad-and-the-ugly">0-1. Dolphins 11, Patriots 21<br /></a><a href="/index.php/9-blog/449-bills-31-dolphins-28-the-good-the-bad-and-the-ugly">0-2. Bills 31, Dolphins 28<br /></a><a href="/index.php/9-blog/451-dolphins-31-jaguars-13-the-good-the-bad-and-the-ugly">1-2. Dolphins 31, Jaguars 13<br /></a><a href="/index.php/9-blog/453-seahawks-31-dolphins-23-the-good-the-bad-and-the-ugly">1-3. Seahawks 31, Dolphins 23<br /></a><a href="/index.php/9-blog/454-dolphins-43-49ers-17-the-good-the-bad-and-the-ugly">2-3. Dolphins 43, 49ers 17<br /></a><a href="http://www.phinfever.com/index.php/9-blog/455-jets-0-dolphins-24-the-good-the-bad-and-the-ugly">3-3. Jets 0, Dolphins 24<br /></a><a href="/index.php/9-blog/457-rams-17-dolphins-28-the-good-the-bad-and-the-ugly">4-3. Rams 17, Dolphins 28<br /></a><a href="/index.php/9-blog/458-dolphins-34-cardinals-31-the-good-the-bad-and-the-ugly">5-3. Dolphins 34, Cardinal 31<br /></a><a href="/index.php/9-blog/460-chargers-21-dolphins-29-the-good-the-bad-and-the-ugly">6-3. Chargers 21, Dolphins 29<br /></a><a href="http://www.phinfever.com/index.php/9-blog/461-dolphins-13-broncos-20-the-good-the-bad-and-the-ugly">6-4. Dolphins 13, Broncos 20<br /></a><a href="http://www.phinfever.com/index.php/9-blog/462-dolphins-20-jets-3-the-good-the-bad-and-the-ugly">7-4. Dolphins 20, Jets 3<br /></a><a href="/index.php/9-blog/463-bengals-7-dolphins-19-the-good-the-bad-and-the-ugly">8-4. Bengals 7, Dolphins 19<br /></a>8-5. Chiefs 33, Dolphins 27</strong></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Chiefs 33, Fins 27 Highlights</h3></div><div class="dd-blockcontent"><div class="sp_simple_youtube">
					<iframe title="Simple youtube module by JoomShaper.com" id="sp-simple-youtube131" src="http://www.youtube.com/embed/g_PZu0IAjbo?wmode=transparent" frameborder="0"></iframe>
			</div>
			<script type="text/javascript">
			window.addEvent("domready", function() {
				spsyt('sp-simple-youtube131', 200, 145);
			});
			window.addEvent("resize", function() {
				spsyt('sp-simple-youtube131', 200, 145);
			});
		</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Draft Central</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a title="Phinfever Draft Central with Dan Jamroz" href="/index.php/draft-central"><img style="display: block; margin-left: auto; margin-right: auto;" src="http://www.phinfever.com/draft/banner_draftCentral_2017.gif" alt="Phinfever Draft Central - Complete Info On Miami Dolphins' draft picks." /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Books</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="https://www.amazon.com/dp/B07T2F5F1C/" target="_blank"><img style="display: block; margin-left: auto; margin-right: auto;" src="http://www.phinfever.com/images/banners/book-DanMarino.gif" alt="&quot;In Defense of Dan Marino&quot;" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Podcasts, Interviews</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="https://itunes.apple.com/us/podcast/dolphinstalk-com-daily/id1289046573?mt=2" target="_blank"><img src="http://www.phinfever.com/images/banners/banner_DolphinTalk-2018.png" alt="DolphinsTalk.com" width="200" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Phinfever FFL</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;"><a href="https://www71.myfantasyleague.com/2020/home/21714#0" target="_blank"><img src="/images/banner_TRockFFL01.jpg" alt="T-Rock's Phinfever FFL 2014" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Phinfever - Jeopardy</h3></div><div class="dd-blockcontent"><div class="sp_simple_youtube">
					<iframe title="Simple youtube module by JoomShaper.com" id="sp-simple-youtube112" src="http://www.youtube.com/embed/XD5d-0S_RZo?wmode=transparent" frameborder="0"></iframe>
			</div>
			<script type="text/javascript">
			window.addEvent("domready", function() {
				spsyt('sp-simple-youtube112', 200, 200);
			});
			window.addEvent("resize", function() {
				spsyt('sp-simple-youtube112', 200, 200);
			});
		</script></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Armando Salguero</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a class="twitter-timeline" href="https://twitter.com/ArmandoSalguero?ref_src=twsrc%5Etfw" data-width="200" data-height="400" >Tweets by ArmandoSalguero</a> &nbsp;</p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Barry Jackson</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a class="twitter-timeline" href="https://twitter.com/flasportsbuzz?ref_src=twsrc%5Etfw" data-width="200" data-height="400" >Tweets by flasportsbuzz</a> &nbsp;</p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Dave Hyde</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<a class="twitter-timeline" data-width="200" data-height="400" href="https://twitter.com/davehydesports?ref_src=twsrc%5Etfw">Tweets by davehydesports</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></div></div>



                        </div>

                        <div class="dd-layout-cell dd-content">
<!-- begin nostyle -->
<div class="dd-nostyle">
<!-- begin nostyle content -->
<!-- JSN IMAGESHOW FREE 4.8.1 - Theme Slider 1.1.7 --><div class="jsn-container"><div class="jsn-gallery"><div id="jsn-themeslider-skitter-GL06C"><div style="width: 500px; height: 300px;" class="box_skitter jsn-themeslider-gallery jsn-themeslider-skitter-GL06C">
<ul><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg" alt="001.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">001.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg" alt="002.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">002.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg" alt="003.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">003.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg" alt="004.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">004.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg" alt="005.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">005.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg" alt="006.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">006.jpg</p></div>
					 </li><li>
			   			<a href="javascript:void(0);" >
			   				<img src="http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg" alt="007.jpg"/>
			   			</a>
			   			<div class="label_text"><p class="jsn-themeslider-caption-title">007.jpg</p></div>
					 </li></ul><input type="hidden" class="cache_skitter_index" value="" /></div>
</div><script type="text/javascript">
						jsnThemeSliderjQuery(function() {
						jsnThemeSliderjQuery(document).ready(function(){
							var wrap_width = parseInt(500);
							var window_width = parseInt(jsnThemeSliderjQuery(window).width());
							if (wrap_width > window_width) {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-GL06C').css("width", "100%");
							} else {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-GL06C').css("width", "500px");
							}
							var oldHTML = jsnThemeSliderjQuery('#jsn-themeslider-skitter-GL06C').html();
							var options = {"animation":"random","navigation":true,"navShowOnMouseOver":true,"dots":false,"numbers":false,"caption_title_css":"font-family: Verdana;\r\nfont-size: 12px;\r\nfont-weight: bold;\r\ntext-align: left;\r\ncolor: #E9E9E9;","caption_description_css":"font-family: Arial;\r\nfont-size: 11px;\r\nfont-weight: normal;\r\ntext-align: left;\r\ncolor: #AFAFAF;","caption_link_css":"font-family: Verdana;\r\nfont-size: 11px;\r\nfont-weight: bold;\r\ntext-align: right;\r\ncolor: #E06614;","caption_position":"bottom","caption_caption_opacity":"filter:alpha(opacity=75);opacity: 0.75;","interval":6000,"controls":false,"stop_over":true,"auto_play":true,"caption_title_show":true,"caption_description_show":true,"caption_link_show":false,"label":false,"animateNumberActive":{"backgroundColor":"#CC3333","color":"#fff"},"click_action":"no_action","open_link_in":"current_browser","skitter_class_id":"jsn-themeslider-skitter-GL06C"};
							options.base_height = 300;
							jsnThemeSliderjQuery('.jsn-themeslider-skitter-GL06C').skitter(options);
							jsnThemeSliderjQuery('.jsn-themeslider-skitter-GL06C .image_main').css("max-width", "");
							var jsn_GL06C = jsnThemeSliderjQuery(window).width();
							var cacheResize;
							jsnThemeSliderjQuery(window).resize(function (e) {
								if (jsn_GL06C != jsnThemeSliderjQuery(window).width())
								{
									clearTimeout(cacheResize);
									cacheResize = "";
									var oldCacheIndex = jsnThemeSliderjQuery('#jsn-themeslider-skitter-GL06C .cache_skitter_index').attr('value');
									jsnThemeSliderjQuery('#jsn-themeslider-skitter-GL06C').html(oldHTML);
									var wrap_width = parseInt(500);
							var window_width = parseInt(jsnThemeSliderjQuery(window).width());
							if (wrap_width > window_width) {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-GL06C').css("width", "100%");
							} else {
								jsnThemeSliderjQuery('.jsn-themeslider-skitter-GL06C').css("width", "500px");
							}
									jsnThemeSliderjQuery('#jsn-themeslider-skitter-GL06C .cache_skitter_index').attr('value', oldCacheIndex);
									var options = {"animation":"random","navigation":true,"navShowOnMouseOver":true,"dots":false,"numbers":false,"caption_title_css":"font-family: Verdana;\r\nfont-size: 12px;\r\nfont-weight: bold;\r\ntext-align: left;\r\ncolor: #E9E9E9;","caption_description_css":"font-family: Arial;\r\nfont-size: 11px;\r\nfont-weight: normal;\r\ntext-align: left;\r\ncolor: #AFAFAF;","caption_link_css":"font-family: Verdana;\r\nfont-size: 11px;\r\nfont-weight: bold;\r\ntext-align: right;\r\ncolor: #E06614;","caption_position":"bottom","caption_caption_opacity":"filter:alpha(opacity=75);opacity: 0.75;","interval":6000,"controls":false,"stop_over":true,"auto_play":true,"caption_title_show":true,"caption_description_show":true,"caption_link_show":false,"label":false,"animateNumberActive":{"backgroundColor":"#CC3333","color":"#fff"},"click_action":"no_action","open_link_in":"current_browser","skitter_class_id":"jsn-themeslider-skitter-GL06C"};
									options.base_height = 300;
									cacheResize = setTimeout(function () {
										jsnThemeSliderjQuery('.jsn-themeslider-skitter-GL06C').skitter(options);
										jsnThemeSliderjQuery('.jsn-themeslider-skitter-GL06C .image_main').css("max-width", "");
									}, 500);
									jsn_GL06C = jsnThemeSliderjQuery(window).width();
								}
							});
						})});
				</script><div class="jsn-themeslider-seocontent">
<p>Joomla gallery extension by <a href="http://www.joomlashine.com" title="Joomla gallery">joomlashine.com</a></p>
<div><p>2015 Dolphins Draft Picks</p><p></p><ul><li><p>001.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/001.jpg</a></p></li><li><p>002.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/002.jpg</a></p></li><li><p>003.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/003.jpg</a></p></li><li><p>004.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/004.jpg</a></p></li><li><p>005.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/005.jpg</a></p></li><li><p>006.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/006.jpg</a></p></li><li><p>007.jpg</p><p><a href="http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg">http://phinfever.com/images/slideshow/2015-05_Rookies/007.jpg</a></p></li></ul></div></div>
</div></div><!-- end nostyle content -->
</div>
<!-- end nostyle -->
<article class="dd-post dd-messages"><div class="dd-postcontent clearfix">
<div id="system-message-container">
</div></div></article><div class="item-page"><article class="dd-post"><div class="dd-postmetadataheader"><h2 class="dd-postheader"><a href="/index.php/9-blog/465-chiefs-33-dolphins-27-the-good-the-bad-and-the-ugly">Chiefs 33, Dolphins 27 - The Good, The Bad and The Ugly</a></h2></div><div class="dd-postheadericons dd-metadata-icons"><span class="dd-postdateicon">Published: Monday, 14 December 2020 11:04</span> | <span class="dd-postauthoricon">Written by Rich Rodriguez</span> | <a href="/index.php/9-blog/465-chiefs-33-dolphins-27-the-good-the-bad-and-the-ugly?tmpl=component&amp;print=1&amp;page=" title="Print" onclick="window.open(this.href,'win2','status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=yes,width=640,height=480,directories=no,location=no'); return false;" rel="nofollow"><img src="/templates/dd_goldenline_32/images/system/printButton.png" alt="Print" /></a> | <a href="/index.php/component/mailto/?tmpl=component&amp;template=dd_goldenline_32&amp;link=d3cfc5555307176edb1c83b5d1a6a0a7b59b9f85" title="Email" onclick="window.open(this.href,'win2','width=400,height=350,menubar=yes,resizable=yes'); return false;"><img src="/templates/dd_goldenline_32/images/system/emailButton.png" alt="Email" /></a> | Hits: 32</div><div class="dd-postcontent clearfix"><div class="dd-article"><p><strong>The Good</strong></p>
<p>Even though the Chiefs scored 33 points (24 were allowed by the defense), you have to give your hats off to the defense and the way they play. Mahomes threw 3 interceptions and was sacked 3 times. Jerome Baker stood out with 2.5 sacks. Xavien Howard continues his ridiculous streak, leading the league in interceptions. This defense played more than well enough to win.</p>
<p>Mike Gesicki was belling before injuring his shoulder. He had 2 TDs and 65 yards. Lynn Bowden Jr showed up nicely with 7 catches for 82 yards. Mack Hollins also had a nice game with 66 yards. It is nice to see some of these back-up players pick up the slack.</p>
<p><strong>The Bad</strong></p>
<p>The running game went back to it's putrid, unproductive ways. Granted we are down two running backs. DeAndre Washington showed very little of anything. Maybe we need to see more Patrick Laird as he actually produces when he is in the game. The Dolphins run a lot of playaction and other action that depends on a strong running game in opening up the second level of the defense. Since no one respects our running game, you often see nothing happening out of playaction. Receivers are well covered. Linebackers are dropping back far enough to take away the middle of the field. The lack of a running game has a massive domino effect on this entire offense.</p>
<p><strong>The Ugly</strong></p>
<p>It was a tail of two halves again with Tua. He was not very effective in the 1st half but took over the game in the second half. The hurry-up offense is a strength for him. The less he has to think and the more he plays on instinct, the better he performs.</p>
<p><strong>Overall</strong></p>
<p>The Dolphins had a solid showing against a clearly superior football team. We all expected a loss and at one point, it was looking like a blowout. The Dolphins did enough in the 2nd half to keep it interesting and the performance by the defense against an elite offense was inspiring. The performance by the team overall given the significant injuries to this team showed that the culture and mentality in Miami have changed. The Dolphins are still in good position for a playoff spot, but more importantly, they are in very good position to continue rebuilding this team the coming offseason.</p>
<p>Next up are the Patriots. The Dolphins team they will be facing is significantly different from the one they beat earlier in the season.</p> </div><div class="dd-pager"><a href="/index.php/9-blog/464-going-the-distance" rel="next">Next &gt;</a></div></div><div class="dd-postmetadatafooter"><div class="dd-postfootericons dd-metadata-icons"><span class="dd-postcategoryicon">Category: <span class="dd-post-metadata-category-name"><a href="/index.php/9-blog">Blog</a></span></span></div></div></article></div>


                        </div>
                        <div class="dd-layout-cell dd-sidebar2">
<div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Support Phinfever</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p style="text-align: center;">&nbsp;<a title="Donate to Phinfever" href="https://www.paypal.com/us/verified/pal=bigdave1261%40bellsouth%2enet" target="_blank"><img src="/images/verification_seal.gif" alt="verification seal" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Next Game</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p align="center"><a title="Next Game" href="https://www.miamidolphins.com/schedule/" target="_blank"><img title="Next Game" src="/2020/2020_week15.jpg" alt="Week 15: New England Patriots at Miami Dolphins, 1 pm on CBS" width="180" height="200" /></a></p>
<p align="center"><img src="/2020/2020standings_14b.gif" alt="AFC East Standings" /></p>
<p align="center"><a href="http://www.tankathon.com/nfl" target="_blank"><img src="/2020/21draftOrder14a.gif" alt="2021 NFL Draft Order" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2020 Draft (Grier)</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/component/content/article?id=432:2020-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2020-2020a.gif" alt="2020 NFL Draft (Grier)" width="200" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2019 Draft (Grier)</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/component/content/article?id=398:2019-nfl-draft-coverage-phinfever"><img style="float: left;" src="/draft/preview-draft2019-2020a.gif" alt="" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2018 Draft (Grier)</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a title="Phinfever's 2018 Miami Dolphins Draft Coverage" href="/index.php/component/content/article?id=353:2018-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2018-2020b.gif" alt="2018 Miami Dolphins Draft (Grier)" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2017 Draft (Tnbaum)</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/component/content/article?id=306:2017-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2017-2020b.gif" alt="2017 Miami Dolphins Draft (Tannenbaum)" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2016 Draft (Tnbaum)</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="/index.php/11-draft-central/217-2016-nfl-draft-coverage-phinfever"><img src="/draft/preview-draft2016-2019c.gif" alt="2016 Miami Dolphins Draft, Phinfever" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">2015 Draft (Hickey)</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a href="http://www.phinfever.com/index.php/9-blog/123-2015-nfl-draft-coverage-phinfever" target="_blank"><img style="display: block; margin-left: auto; margin-right: auto;" src="/draft/preview-draft2015_03.gif" alt="" /></a></p></div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">MiamiDolphins.com</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<a class="twitter-timeline" data-width="200" data-height="400" href="https://twitter.com/MiamiDolphins?ref_src=twsrc%5Etfw">Tweets by MiamiDolphins</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></div></div><div class="dd-block clearfix"><div class="dd-blockheader"><h3 class="t">Cameron Wolfe</h3></div><div class="dd-blockcontent"><div class="custom"  >
	<p><a class="twitter-timeline" href="https://twitter.com/CameronWolfe?ref_src=twsrc%5Etfw" data-width="200" data-height="400">Tweets by CameronWolfe</a> &nbsp;</p></div></div></div>

                        </div>
                    </div>
                </div>
            </div>

<footer class="dd-footer">
<span style="font-size: 12px; color: rgb(255, 255, 255);"><span style="color: rgb(255, 255, 255);">Copyright</span>&nbsp;© 2014</span> <span style="font-size: 12px; color: #F9DA6C;">... Phinfever.com ... since 1999</span>
</footer>

    </div>
    <p class="dd-page-footer">
        <span id="dd-footnote-links">Designed by <a href="http://www.diablodesign.eu" target="_blank">www.diablodesign.eu</a>.</span>
    </p>
</div>


</body>
</html>